Symlinking a vault to My Drive from a shared drive

Hello! Sorry if the title doesn’t make much sense, I didn’t know how to word it.

I have made a vault in a shared drive (you should know I’m using Google Drive by now). I can access everything normally on my desktop, but I’m having issues accessing the vault on my iOS device. I have tried making a shortcut to the vault to My Drive, but it’s not working. I have tried both right clicking and pressing shift-z on the vault folder (as described here), but both result in the shortcut being shown as a file. This makes it impossible to unlock the vault. I have tried using both the original Cryptomator app and the new Cryptomator app; both do not work.

Is there any way I can either access the shared drive directly or use another method to make a shortcut to My Drive?

That actually surprises me. The new Cryptomator app should be able to resolve Google Drive shortcuts automatically since version 2.2.0. Are you sure that you tried it with the latest version?

I’m sure both the apps are up to date. Cryptomator 2 is on version 2.2.0 and the original Cryptomator is on version 1.6.3.

Maybe I should add that whenever the shortcut is in My Drive, Cryptomator 2 stops working for Google Drive and starts showing a “‘/’ could not be found” error. (“drive” is the name of the folder containing the vault.


Oh, I see. Looks like this issue then: Browsing directory in Google Drive fails with itemNotFound error · Issue #194 · cryptomator/ios · GitHub

And maybe this won’t be fixed with 2.2.1. I originally thought that this only happens with “unresolvable” shortcuts that have to be skipped. But maybe there are different kinds of shortcuts? Will have to investigate this, thank you for reporting!

You’re welcome. So do you know any workarounds to get it to work?

@stormzyy just sent you a direct message regarding this topic :slight_smile:

Thank you for helping us out, @stormzyy! It will be fixed with the next update 2.2.2.

1 Like

Alright! Thank you guys for all your help!

Hello again! I’m replying about this situation again because of another problem. In the new Cryptomator 2 app, the folder which couldn’t be shown before is shown, but when opening the folder, nothing is inside it. I have again tried pressing shift-z and right-clicking → add shortcut to drive but it doesn’t work. I have attached some screenshots to show the problem.

Yeah… well… we shouldn’t have tested this with empty folders. :confounded: Will look into it. Empty folder inside a shortcut in Google Drive · Issue #204 · cryptomator/ios · GitHub

I’ve already tested some other API calls in Google Drive but the result is always empty. @SailReal It would be great if we could compare this with Android again.

1 Like

@tobihagemann oh no :see_no_evil: yes, the folder is empty using the Android app as well and I’m unable to create a folder using the Android app inside this shared folder. Hmmm :thinking: but when I do the same using a shared folder from the Computers location, everything works as expected so it must be a specific thing in the Shared Drives. It works too when a folder is shared from a Computers location with a second account b and the account b creates a shortcut to My Drive, everything works.

So its IMO not the sharing with a second account itself and specific to Shared drives.

1 Like

I’ll have to read up on it a little more but setting

fileListQuery.includeItemsFromAllDrives = true
fileListQuery.supportsAllDrives = true

fixed the problem.



Alright, nice! Is there any way I can set these flags on iOS or do I have to wait for an update?

Unfortunately, this requires an update (both on Android and on iOS). But it looks like that we found the solution. Just doing some more testing right now so that it doesn’t up with the next malfunction. :smile:

Alright! Thank you guys for helping!

I have updated to Cryptomator 2 v2.2.3, and the problem is fixed! Thank you guys for helping fix the issue!