Stable or still risky? -olocal -oallow_root to allow file search on Mac

Hi - I just got finder and spotlight to find files via -olocal and -oallow_root. Great!

What is still not clear to me after reading through all related threads: Is it ok to use this as of today or am I risking to lose my files? Which I cannot afford …

Thanks for any clarification!
Peter.

Sorry for beeing offtopic and not answering your question directly (hopefully one other can), but as you pointed out to that I have to leave my comment :slight_smile:

There is always, at any second and regardless of the software and hardware used, the risk of data loss. If you can’t afford that, then you have no choice but to have a good backup strategy.

Thanks. No need to educate on the need for backups. “Cannot afford” might be misleading. Take it as “I would not want to play guinea pig” :grinning:

Again: Would you recommend -olocal -oallow_root for production use in the meantime?

@justmakeitwork just to understand, could you give some details on how you achieved the use of Spotlight on Cryptomator volumes on Mac OS ? May I ask you which version of Mac OS and Cryptomator you are using ? Up until recently this didn’t seem to work, see https://github.com/cryptomator/cryptomator/issues/937 to which no answer/solution has been given so far. Thank you for your kind reply!

Sure - have also been confused on the status, that is why I tried it out as:

  • MacOS BigSur 11.2.3, Cryptomator 1.5.14, macFUSE 4.1.0
  • Test Vault, custom mount options default + -olocal -oallow_root
  • Copy some test files into test vault
  • Wait 1-2 min

Files show up both in Finder Search and Spotlight.

Does that help? Can anyone else confirm it works?

OK be careful, quick update:

  • No, it does not work reliably
  • Files I copied into the volume revealed ended up somewhere in the local FS, which I noticed when files still were there even after having locked the vault
  • This explains that they were indexed by spotlight
  • Manual removal, playing with options led to finder freeze, cold boot etc … dangerous game
  • Clean attempt manages to unlock the vault with -olocal, -oallow_root, however spotlight and file indexing did not work

My summary: Stay away for now.

© 2021 Skymatic GmbH • Privacy PolicyImpressum