[SOLVED] Windows 10 desktop app 1.4.3 error trying to access the drive

Hello,

I have just updated from windows 10 desktop app 1.4.2 (working perfectly well) to 1.4.3

I cannot remember whether I installed dokany in 1.4.2 so when updating I have kept the new install dokany-free.

The drive mounts ok and folder contents can be accessed, files opened etc. However, pasting new data (files/folders) so that they are encrypted does not seem to work. I get the following error: “Error when trying to access drive. Make sure you are connected to the drive and try again”.

I have unistalled 1.4.3, and installed 1.4.3 + Visual C++ redistributable as recommended in Downloads section. Rebooted the OS. Launch the app, and it is just the same situation as described above.

Any tips are welcome and thank you for reading.

Edit: I forgot to add this happens with contents encrypted locally and in Google Drive. Cannot say for other cloud services.

143 now has the option to mount drives Read Only, worth checking in “more options” this isn’t ticked?

Oh my… @Amiga1200Gamer thank you for you feedback
The fact is in the meantime I have downgraded to 1.4.2 and it’s all back to normal. I have now installed 1.4.3 dokan-free but cannot see an option to mount/unmount read only either in Settings or More options. So, where should it be?

Regards,

Right below where you enter your password (before mounting) press more options, you should see Save Password, Auto Unlock, Drive Name, Reveal Drive and Read Only

Yes, that is where I checked. However I can see:
Advanced options:
Save password
Auto Unlock (experimental)
Drive name (editable textbox)
Reveal drive
Use custom mount point
Drive letter (auto-assign)

So no Read only.

But I think I have found the reason: while the English interface shows the text, translations do not show it unless that string is translated. So probably by default the drive is mounted read only but cannot be unclicked to allow read+write.

I have checked that the Spanish translation for the Read-Only string (unlock.label.useReadOnlyMode) and is showing as not translated yet.

I cannot confirm but that might be the issue?

Regards,

Edit: uninstalled 1.4.3 and installed 1.4.3 full (with dokany 1.2.1.1000 (x86)). This time, copying to encrypted folders works as expected (no drive errors as described above). Still, Read-Only text it not showing in non-English interfaces.

Read-Only is only present for FUSE and WebDAV drives. In Dokany it was too buggy, therefore we didn’t release it yet. But it will be coming with one of the next updates.

Hi everybody,

I just wanted to let you know, that I have the same problem. I can access my files and copy them from the vault somewhere else, but I can’t paste new files into the vault. I don’t see the ‘Read-Only’-Option either and installing and uninstalling (full version or not) does not do the trick for me. Any other guesses?

Help is very much appreciated. Thanks!

Edit: Downgrading to 1.4.2 solves my problem

FYI:
Similar problem here with 1.4.3: After Changing a txt- or Word-document changes can not be saved. Sorry, didn’t make a screenshot of the error message. Was something like “network problem”. Problem was seen on two different machines. Vault is used in WebDAV-Mode. Cloud software is MagentaCloud from Telekom.

Unfortunately I didn’t check the Read-Only Option, but did not tick it myself. Maybe it is enabled by default after upgrading to 1.4.3?

Donwgrading to 1.4.2. solved the problem on both machines.

Upgraded to 1.4.3 in my VM for testing purposes:
Read-Only (“nur lesend”) is visible but NOT checked.
Problem persists: changes in txt-documents can not be saved (tried Notepad++ and Windows-Editor).

error-message: “Nicht alle Daten für die Datei \cryptomator-vaultq42427\DavWWWRoot\JHSGDH\hjfgfshg\testdatei.txt konnten gespeichert werden. Daten gingen verloren”. Which translates to " Not all data for file \cryptomator-vaultq42427\DavWWWRoot\JHSGDH\hjfgfshg\testdatei.txt could ba saved. Data was lost."

As confirmed in previous message issue was solved in 1.4.3 if Dokany and Microsoft Visual C++ Redistributable for Visual Studio 2017 were installed as well.

I can confirm after testing there are no issues with 1.4.4 using Windows 10. This time the installer only installed 1.4.4 since Dokany was already installed.

This has been solved with today’s hotfix release 1.4.4.

Hello,
sorry for intervening, but imho the issue with Dokany is not solved under Windows 10. Using Dokany access Cryptomator (even 1.4.15) still complains about saving any changes or new files. Switching back to WEBDAV works. But this can’t be the solution.

P.S. I appreciate your great work.

@SMaster Can you elaborate what is not working/ what the reported error is?