SOLVED (Dismount drive first!): Can't change vault password as GUI doesn't show a menu on right click

I was stumped on trying to change a vault password until I came across a question on this site (How can I change my password?) which showed a right click menu to use. However, when I right click I get nothing. Any suggestions?


What version of Cryptomator and what operating system are you using? Do you have a HiDPI display?

Hi. I’m on Windows 10, using the latest Cryptomator 1.3.3 (downloaded this morning) and not using a high DPI display (although I have two monitors - 1920x1080 and 1680x1050). Cheers.

I just tried it on my laptop which does have a HiDPI display and that doesn’t show the context menu either. Both also have the task bar menu issue where the menu display but with no text and squashed.

same here with Version 1.3.3 and Windows 10
(never noticed).

No HiDPI Display (1920x1080)

I was literally just entering a bug report in Git for this issue when I went to check the version in the app and lo and behold the right click menu is there now. What has changed? I had to restart the machine as I moved everything into a new case. Coincidence? Who knows. Anyway, now it is working so for anyone else having the same problem may like to try a reboot.

I’m on a pc an reboot every night. This does not work for me. Very confusing.

OK. I’ve figured it out. I got back from work this evening and lo-and-behold the menu was not working. After some bemusement I had a lightbulb moment and thought, “Did I try the right menu before I mounted the drive last time?”. I unmounted the drive and the right menu nows works. Conclusion: right menu does not appear when a drive is mounted. Now, although this is logical given the contents of the menu (Change password & Remove from list) it is extremely confusing and it would be much better to display an empty menu with no items or at least a placeholder.

I admit that it’s confusing but the guide mentioned this at the end. :sweat_smile:

The password can be changed by right-clicking on a vault while it is locked.

I’ve added another sentence that the password can’t be changed while the vault is unlocked.

In my backlog, I’ve already noted the question if it’s even necessary that the vault is locked. I’ve created a GitHub issue so that it’s not in my own backlog anymore. :wink:

1 Like

Guide? What guide :wink: Thanks for getting back and raising the issue on GitHub plus many thanks for developing this incredibly useful piece of s/w. I still can’t understand why companies like Synology produce a private “cloud” sync product which doesn’t include a client-side encryption option (like DropBox does) and Cryptomator addresses that gap very nicely.

The guide you’ve linked in the beginning: How can I change my password?

I was just teasing as I would suggest that few people read the guide or even know of it; hence the wink. :grin:

1 Like