Secure screen setting in Cryptomator for Android

Android provides the possibility, to prevent the system and other apps from doing screen shots, screen recording etc while Cryptomator is active. This feature is very important because it prevents other apps from reading data across the screen.

This feature is enabled for all our views. For some devices e.g. a Chromebook with a second display or to create a screenshot and disable it again, we made this option since the 1.3.9 configurable. The screen is secured by default but under Settings --> Screen security, it is possible to disable or reactivate this feature.

If you want to read more about it: FLAG_SECURE

1 Like

That’s interesting, and I may be seeing this problem on my Chromebook, as the Cryptomator android app briefly flashes the robot but then goes to black window. Like it might be trying to prevent a screen shot. However, with the black app window, I cannot get into (or even find) the settings to disable this Screen Security flag. Is there a key combination maybe?

There is no key combination or something similar. Do you have root access? Then you can change the flag directly in the settings file: /data/data/org.cryptomator/shared_prefs/org.cryptomator_preferences.xml.

Set the following properties to false:

<boolean name="secureScreen" value="false" />
<boolean name="disableAppWhenObscured" value="false" />