Resilio Sync: "The selected folder is not a vault."

I tried using an existing vault, synced it to my iPhone using Resilio sync, and got the error “The selected folder is not a vault.”

I then tried creating a new empty vault, then synced it to my iPhone using Resilio Sync. Same Error.

I tried checking the health of both vaults from my Mac and both were fine, they also open fine on Mac. Synchronization looks correct with exact number of files on both sides and same file size.

Logs said:
2022/09/24 23:20:07:890 Error: domainNotFound
2022/09/24 23:20:21:235 Error: domainNotFound
2022/09/24 23:21:58:822 Error: domainNotFound
2022/09/25 07:46:22:086 Error: domainNotFound
2022/09/25 07:46:45:224 Error: noVaultFound
2022/09/25 07:46:51:662 Setting trialExpirationDate was removed
2022/09/25 07:46:51:662 Setting fullVersionUnlocked was written with value true
2022/09/25 07:46:51:662 Setting hasRunningSubscription was written with value false

2022/09/25 07:46:51:697 FPExt: persistentIdentifierForItem(at: file:///var/mobile/Containers/Shared/AppGroup/F510496F-C1CE-416E-9B9D-01B8E34152D3/File%20Provider%20Storage/F7E4327B-298F-48AF-B807-E5E8128C3BC4/db.sqlite) called

Any advice?

Same issue here.

MAC/PC->iPhone doesn’t seem to work