Problems with Cryptomator on iOS


I created a Cryptomator vault under OSX on a Google Drive cloud share. This appears to have worked nicely
and synchronised OK.

Then I tried to access the vault with the iOS app as downloaded yesterday. The iOS is 10.3.3 on an iPad.
When I try to add the vault by hitting the GoogleDrive button the window just goes away and nothing happens.
The same when I try to create anew vault under iOS. Hit the GoogleDrive button, window goes away.

Cryptomator does not seem to die completely, in the iOS task thingie, the green background is still available.

The GoogleDrive itself seems to be happy: I can see the Cryptomator generated files in the GoogleDrive App.

Am I doing something wrong or is this a bug?

The window goes away because it opens up a new window for authentication to Google (we’re using GTMAppAuth to be exact). Sounds like an issue that the Google authentication website is not loading. Just tested it here again and it seems to be loading just fine.

Even though you’ve confirmed that the Google Drive app is working, maybe it’s a network hiccup? Or maybe you have some blockers installed for Safari that doesn’t load Google contents?

I’m using google drive as well with iOS. Can confirm that everything is working fine.

Thanks Tobi,

your message brought me on the right track. I still had a standing login on GoogleDrive in iOS, from
using GoogleDrive obviously. When I logged that one out and logged in from Cryptomator everything
started working. Nevertheless I would appreciate a more meaningful error indication for this other then
a windows closing and then nothing.

1 Like