Performance Issues with 1.5.5

I started using Crytomator a couple of years ago, but jumped straight to Mountain Duck, so had very little experience with the core Cryptomator app. I now want to use just the Cryptomator app, but am having some serious performance issues where browsing directories, loading files etc result in freeze-ups, long delays etc. From reading other posts here; I’ve seen similar issues reported with earlier versions, but many posts indicating that the performance I’m experiencing isn’t normal.

My setup: Cryptomator 1.5.5, Windows 10 (1909), Unifi networking gear, vaults stored on a Synology Diskstation on my local network. Network otherwise working fine and typically not congested. Both vaults I use are large, containing several hundred GB - mixture of archives, media, documents. I don’t have any “applications” running from the vaults.

Background: I started using Cryptomator a couple of years ago, but started with the Mountain Duck app. I had some initial performance problems (same as I am experiencing now), but found that selecting the SFTP protocol made things adequate.

Current Problem: Vault access is very slow. Browsing from one directory to another often takes 30+ seconds, small sub-1mb files can sometimes be relatively fast, but often sometimes take a long time to load. Sometimes trying to change directories causes a long pause, but the directory doesn’t actually change. Opening larger. files e.g.: 2gb video might take a few minutes to appear and then require repeated buffering in VLC player every few seconds. I don’t get any thumbnails generated at all when browsing directories. Overall this makes Cryptomator quite unusable in a practical way. I’ve noticed that after clicking to change folder, or load a file; the entire cryptomator drive seems to freeze; I can’t click to a different icon and the windows title bar will show a “not responding” message. During these long pauses, the Cryptomator app window is still responsive, but the read/written shows “idle”. However, if I look at the network tab in Windows “Task Manager” I get a spike in network traffic of “Send: 0.9-1.3Mbps” and a similar amount of traffic on “Receive”. This lasts for the duration of the pause.

Things I Have Tried:

  • Switching from Dokany to WebDav - doesn’t seem to make much difference. If anything, WebDav seems worse; but I get the same behaviour characterised by long pauses.
  • Using custom mount options with Dokany - I read people had improved performance by increasing the thread/timeout values by a factor of 10. This doesn’t seem to make a difference for me.
  • Diabling WIndows Defender firewall - I’ve done this through the control panel - no change. I tried using a custom registry key, but upon restart, I wasn’t sure whether Defender was truly disabled as I could still access the control panel for it. I read in another thread that someone ran Wireshark on their machine and saw crytomator resulted in “the SMB protocol sends a special request for each file: “GetInfo Request: FILE INFO”. This request is answered with “INVALID_INFO_CLASS”. I guess that’s the reason for the hugh traffic”. This feels really similar to my problem.
  • Disabling 3rd Party Anti-Virus/Malware software: I was running Avast, Malwarebytes and CCleaner. I’ve tried uninstalling these, but again no difference.
  • Disabling as many non-vital apps as possible - I’ve uninstalled OneDrive, DropBox, Megasync, Resilio and tried running Crytomator with as little active on the system as possible. No difference.
  • Making a new vault with not many files. This does seem faster: I can make a new vault and copy files to it, I get an average of over 10MB/s copying files into the share. This would appear plenty fast enough to have quite snappy performance for browsing uploaded files. (Although if I try to change directories in one of my older vaults, I get the dreaded “pause” again and the transfer to the new vault stops for the period that it lasts). WIth a few GB copied to a new vault, things seem OK - I can browse directories and open documents/archives/pictures/video with little to no delay or buffering. I still don’t get any thumbnails generated. This might seem to suggest it is a problem with my vaults, or files inside my vault. One of them is all family photos/videos that I’ve taken/scanned myself - so pretty standard picture/video formats and things like a Adobe Lightroom catalogue file.

I’d really like to figure out what the problem is. Given that Cryptomator is so obviously working great for so many others, I think my system/config/vault contents are causing some sort of issue. Grateful for any advice as to what I can try or steps to troubleshoot.

Thanks!

Have you tried mounting the share as a windows SMB/CIFS type, rather than SFTP ?

Windows 10 can get confused with browsing network devices sometimes, recommend try mounting your share with \NAS_INTERNAL_IP_ADDRESS\ShareName
This is especially important if your NAS is setup for remote access, eg synology quickconnect. I’ve seen cases with windows10 where people have connected to the external name, eg: MyNas.synology.me , its routed the connection externally through the quickconnect server. This will slow things down to the speed of your internet connection.

@Amiga1200Gamer: Thanks for replying. To be clear, I don’t use SFTP now - I was only using that with Mountain Duck. Now using only Cryptomator 1.5.5, I believe I am using regular SMB. I’ve not set up anything special on my Synology and I add my vault by typing “\192.168.99.4\Directory” - and that is a static IP for my Synology device. Is there anything else you can think I should check?

Many thanks!

That sounds fine.

The only other thing that stood out in your post was the issue with thumbnail generation. When things are working correctly, this always slows things down initially while windows opens every file to extract a thumbnail.

Perhaps try browsing your photo folders with a dedicated photo management app, to see if the files are correctly scanned and thumbnailed. I personally use XNviewMP. https://www.xnview.com/en/xnviewmp/

If you try this, Be mindful of where you create your XNview database. From a testing/performance standpoint, its better to generate the db/thumbnails on a local drive. From a privacy aspect you’d need to write thumbnails to a vault, but this will slow the performance.

Amiga1200Gamer: Thanks again. I’ve installed XNViewMP and it shows thumbnails as usual. Within Windows Explorer I have thumbnails showing in all other locations other than my Cryptomator shares. I tried making a new vault with just a few pictures - they too don’t show thumbnails. I also get the repeated pauses irrespective of whether there are image files in a given folder; or if I have Explorer set to show thumbnails/details view etc.

As XNview is able to extract and list the thumbnails, it sounds like the media files are intact and decrypting OK.
I’d hoped that trying a different method to view your media might help isolate if there was a problem with explorer/thumbnail generation causing the speed drops…

The only other suggestion I can think of is try making a test vault on your Local hard disk (or copy an existing vault there), to see if there is a networking issue affecting performance retrieving vaults from the synology.

Other than that, I’m not sure what to suggest. - I tend to use cryptomator only to protect cloud data, so speed is limited to my ISP connection anyway. I haven’t done any extensive testing LAN side on large vaults, as my synology shares are already encrypted through DSM6.

Hopefully someone else in the community may have more ideas for you.

© 2020 Skymatic GmbH • Privacy PolicyImpressum