PDF files with highlighted content won't save to vault

I can open PDF files in the vault and I like to fill in the spots with fillable forms (such as from IRS downloads). When I try to save the document, Adobe acts like it’s saving it, but it never really happens.
My only resolution is to copy the file to my desktop, make my changes, then copy it back to the vault.
This was happening in 1.5.xx and also happens in 1.6.1.
Any suggestions?
Thanks in advance!

You can change the Virtual Volume Provider. Cryptomator supports three types:

  • WebDAV: Integrate the unlocked vault as a network share
  • Dokany: Integrate as a virtual volume, requires thirdparty library Dokany
  • FUSE: Integrate as a virtual volume, see WinFSP: How to use it

They all have pros and cons, you need to see which one works. We suggest WinFSP for Windows.

Thank you for your quick response and I apologize for my slow response but this is an important issue to me.
I tried WinFSP and it seems to fix the problem I was having with Adobe files. I noticed the instructions said:
" For vaults with custom mount options enabled, untick the regarding checkbox"

I don’t use custom mount flags, but would like to use a Mount point where I specify the drive letter. I tried this and it appears to work, but I just want to make sure this is a supported mode.

Thank you.

I’ve worked it out so that I don’t need to specify a Mount point.
More details into the original issue:
I’m running Cryptomator 1.6.5.
It’s tax season, so I’m working with PDF files in my vault. When I use Dokany and modify PDF files, I am unable to save changes to the vault. This is what originally reported at the start of this issue.

Per the suggestion, I switched to FUSE and I am able to save the files, however the Archive bit is not reported as set. When I run Robocopy to copy the changes in my vault to my local hard drive, the changed files are not seen. If I switch back to Dokany after changing a file under FUSE, it now shows the Archive bit set.

It appears as if FUSE is not able to report correctly the state of the Archive bit.

Is this a bug in FUSE?

Since the mount point selection is not the “custom mount options”, you don’t have to worry. :wink:

I believe not so much a bug, more a limitation.

FUSE is actually a POSIX (aka not Windows) protocol to integrate a custom filesystem (like Cryptomators cryptofs) into the base filesystem. You need an adapter to translate the protocol into the Windows world. But there settings/options/data, which cannot be mapped because the other side has no means to represent it.

Thanks for the clarification on the Mount point.

Truly a novice, here, but if I understand your answer re: FUSE correctly, it is not able to be updated to incorporate this feature in the future, correct?

Is it possible for Dokany to be updated to allow it to save PDFs that have been edited?