Only upload camera photos?

I have enabled automatic photo upload and it seems to work. However not just on my camera photos but for all images on my phone. For example the vault now also includes hundreds of cover images from my music app. Can I prevent this and only upload actual camera photos?

Hey and welcome to the Cryptomator Community :slightly_smiling_face:,

We are aware of the need for this feature and it is already listed in our issue tracker, see here for further information:

1 Like

Thank you for replying. I see the issue was raised almost two years ago so I guess it is not exactly at the top of the to-do list.

Would adding a .nomedia file to the unwanted folders work?

Update: I tried but that did not help. I wish that a least the uploaded images was in a folder structure so it was easier to identify the camera photos among all the uploaded images.

Very nice idea and would have thought that it would work since these pictures are also excluded from the gallery etc. but too bad!

This is also already tracked in GitHub…but here too, unfortunately, it will take some time before we implement this.

This is going downhill. Since the latest update the auto photo upload doesn’t work at all on my phone (Android 10). I have tried restarting, locking/unlocking the vault, activating/deactivating upload. Nothing can get it started, new photos are not uploaded. I even see in the release notes the update was supposed to have ‘Fixed auto upload via devices running Android version 10’. Quite the opposite on mine :disappointed:

Thanks for your feedback. Can you please send us your log file?

  1. Go to the splash screen in the Cryptomator app (start screen)
  2. Open “Settings”
  3. Tap on “Send log file”
  4. Choose your mail app and send an email to the Cryptomator team

Thanks for your log file.

Just to narrow down the problem further, can you please check in the settings if we still have the “Storage” permission, to do so:

  1. open your device settings
  2. “Apps & notifications”
  3. choose “Cryptomator”
  4. “Permissions”
  5. verify that “Storage” is in the “Allowed” section

I know you have written that you have already done this, but I just want to make sure that the order of the steps fits, please do the following:

  1. Go to Cryptomator settings, disable and re-enable the auto photo upload
  2. Take some pictures, wait about 10 seconds
  3. Unlock the vault you selected for the auto upload (or make sure that “Upload instant” is still enabled and the vault is already unlocked)

Does the files got uploaded or do you still see this “General error during upload” notification?

1 Like

Success! Turned out the app did not have Storage permission. For now the upload works again :smiley:
I am pretty sure I have not denied the app the storage permission manually at any time. Perharps this happened automatically with the latest update? When I got the “General error during upload” notification I pressed it but got no further info on what the problem was.
Anyway, thanks for the help.

Thanks for your tests and prompt response

Oooooh, puuuuh :sweat_smile: that’s “wonderful” news…at least not something completely new.

We had some problems the last weeks with auto upload, it all started with the change to scoped storage in version 1.6.3. as you wrote we fixed it in the last update supposedly for android 10, this can be verified on other devices with 10 but amazingly it was only “broken” on yours by this update and worked before. I don’t want to go into more detail here because it’s quite confusing but we now have a very interesting table of what we have done for which android version, and now also for which device or model, to get it working again for everyone.

The problem you experienced will not be fixed in a (hopefully) last update 1.6.8, unfortunately that is not possible, but we will point out that the permission is missing and ask the user to grant us the permission again, which is revoked on some devices when updating from 1.6.7 to 1.6.8.

Thanks for reporting!

Just FYI: We just implemented the “fix” regarding this permission issue, see and for further details. Version 1.6.8 will be published tomorrow.

Good to hear. I will be watching for a fix for folder selection :wink:

Are there any updates on the progress towards this?
The automatic photo upload function is great, but it’s annoying when all WhatsApp images, screenshots etc. are uploaded as well.

Is there a possibility to speed this up or prioritize it higher in the backlog (e.g. by donating specifically for this function)? I tried to add above GitHub issue in BountySource to place a bounty on it, however, it didn’t work.