OneDrive free up space not working properly in conjunction with Cryptomator

os:windows

#1

Hello,

I just recently started using Cryptomator to store backups of most of my files on OneDrive. The problem is, that once something has successfuly been uploaded into a vault and anything gets changed in that vault “free up space” is not working any more. It’s greyed out to be particular. If I just upload a vault and let it finish and then select “free up space” everything is working as intended but if I add a folder or I think it’s even sometimes happening when I access a file from the vault, I can see the little Icon has changed from the cloud symbol to the small green check mark which indicates that it’s on my local hard drive. As mentioned above the option to free up space is now greyed out and I haven’t found a solution to enable it again. If I check how much space is used locally and in the cloud by that folder/vault it is often showing that the folder I added last remains on the local drive completely and is using up space that I can’t free up by any means except deleting the files from the vault.

Does anyone else experience something similar as I do? My current solution is to have a lot of different faults for every category I’m uploading so if I have to change something I don’t have to reup a huge vault. But that can’t be how every one of you is dealing with this. Is something wrong on my end perhaps?

I’m using Windows 10

Thanks in advance!

(Kurz noch einmal auf Deutsch: Wenn ich Vaults erstellt und gefüllt habe auf OneDrive über Cryptomator kann ich sie problems per Speicherplatz freigeben komplett in die Cloud verfrachten. Sobald ich aber etwas hinzufüge, bspw. einen weiteren Ordner im Vault mit anderen Dateien, habe ich nicht mehr das blaue Cloudsymbol angezeigt sondern den grünen Haken dafür, dass die Dateien Lokal verfügbar seien. “Speicherplatz freigeben” über Rechtsklick auf den Vault ist ab da ausgegraut und lässt sich nicht mehr aktivieren. Es ist dann auch kein reiner Anzeigefehler sondern wenn ich schaue wieviel Platz lokal und in der Cloud verbraucht werden ist es mehr als ein paar Kilobyte. Teils hatte ich schon mehrere Gigabyte die ich nicht mehr loswerden konnte, da die “Speicherplatz Freigeben” Option eben nicht mehr funktioniert)

Vielen Dank für die Hilfe


#2

If you dont want to have the encrypted files locally, I recommend this:

(Wenn du die verschlüsselten Dateien nicht lokal haben willst, dann solltest Du direkt auf Deinen Vault online zugreifen über Cyberduck)


#3

Thanks Michael, I’ll look into it, definitely sounds like a solution to my problem :slight_smile: !