On Android and Chrome I can see my vault files (in gdrive) on unix I cannot

Vault was created in chromeos Pixelbook and is visible in Android. It is also visible on iPhone.
However, when I use the linux package (installed on ubuntu 19.04 using apt) I initially can connect to my Vault but as soon as I connect its name changes to an id (jumble of letters and numbers and -) and I can see no files. Note that on ubuntu 19.04 the share to Google Drive was set up by setting up google in on-line accounts in the settings panel and I can copy unencrypted files between the pc and gdrive.

Note that in addition to the name of my Vault folder changing to a uid jumble of letters and numbers I have no permission to make any changes on this folder and of course my user name on the ubuntu 19.04 machine is different to android and chromeos (pixelbook).

Any help would be appreciated. Thanks

Just to get things straight:
You created a vault on ChromeOS and synced it to GoogleDrive. You can unlock the vault on all systems (including ubuntu), but on ubuntu no files are shown. On ubuntu you access the vault via GNOME online accounts (see here).

If I’m getting you right, then I have bad news for you: This is a known bug, because your Google-Drive storage is mounted as a remote folder via Gnome Online Accounts. To provide access to your vault, Cryptomator uses the FUSE protocol and using it results in errors. Additionally Google does not provide a sync application for any linux distribution

Just to make sure, can you post a Cryptomator log file of your system?


This is normal, the access point of your vault is randomly generated to avoid conflicts. You can change this by selecting a specific mount point in the advanced options.

© 2020 Skymatic GmbH • Privacy PolicyImpressum