Not decryptable due to an unauthentic ciphertext


I am new and testing Cryptomator. Shortly after coping test files, I ran into an issue.

Some files are missing from the mounted drive. I reviewed the log and see “not decryptable due to an unauthentic ciphertext”. i did not change the password. The majority of test files are there and working.

I searched the forum and didn’t see this error mentioned. Any thoughts on why this is occurring, how to prevent it and how to recover from it?

hmmm, this is a tough one. No one seems to have an answer. This isnt good sign!

Which version do you have installed?
When searching the GitHub page there was an issue in 1.3.1 that caused such an error message. But this should have been fixed in 1.3.2.
If your version is not 1.3.3 (latest), please update and try again.

Hi Michael, Yes! 1.3.3

THank you!

I know this is an old topic. But we are seeing this problem and I can’t see any other mention of it anywhere. We have updated to the latest version of Cryptomator. (Full uninstall first,reboot, reinstall).

We have a number of computers using Cryptomator with Google Team Drives and the other computers do not reproduce the issue. To be clear, although we are using Google Team Drives, we do set the folder in question to be “Available offline” so that there are no complications with on-demand syncing etc. We confirmed that the size and file count of the encrypted vault was the same between the problem machine and other machines. So it should be totally unrelated to our cloud sync setup.

In practice this means that on the affected machine, although we can unlock the vault, when we go into a particular folder we cannot see certain subfolders, and when doing a file count in Windows (via folder properties) there is only a fraction of the data there.

The log file is as follows:

12:08:31.063 [main] INFO  org.cryptomator.launcher.Cryptomator - Starting Cryptomator 1.4.15 on Windows 10 10.0 (amd64)
12:08:31.420 [main] INFO  o.c.launcher.IpcProtocolImpl - Received launch args: 
12:08:32.060 [JavaFX Application Thread] INFO  org.cryptomator.launcher.Cryptomator - JavaFX application started.
12:08:32.409 [JavaFX Application Thread] INFO  org.cryptomator.jni.JniModule - loaded WinFunctions.dll
12:08:32.562 [JavaFX Application Thread] INFO  o.c.ui.controllers.MainController - Unable to setPreferencesHandler, probably not supported on this OS.
12:08:45.217 [pool-1-thread-1] INFO  o.c.common.settings.SettingsProvider - Settings saved to C:\Users\######\AppData\Roaming\Cryptomator\settings.json
12:08:46.698 [JavaFX Application Thread] INFO  o.c.ui.controllers.WelcomeController - Current version: 1.4.15, lastest version: 1.4.15
12:09:08.928 [JavaFX Application Thread] INFO  o.c.k.WindowsProtectedKeychainAccess - Unable to load existing keychain file, creating new keychain.
12:09:09.724 [pool-1-thread-1] INFO  o.c.common.settings.SettingsProvider - Settings saved to C:\Users\######\AppData\Roaming\Cryptomator\settings.json
12:09:41.822 [Background Thread 2] INFO - Dokany version: 130
12:09:41.822 [Background Thread 2] INFO - Dokany driver version: 400
12:09:57.314 [Thread-427] WARN  o.c.cryptofs.CryptoDirectoryStream - G:\######\######\d\EE\G76HJQF2TTXMGHNKROHXC6O2QSQ76R\0CDV4LTRZAOPT4AUO5SRTPA2C7MNNI7TIIXVG7WTAIWL62UHKXA====== not decryptable due to an unauthentic ciphertext.
12:09:57.316 [Thread-427] WARN  o.c.cryptofs.CryptoDirectoryStream - G:\######\######\d\EE\G76HJQF2TTXMGHNKROHXC6O2QSQ76R\0FN4QDXLAQI7ECRJKTJK3PWLENY3Q4IHLLCIOUIQD7J7SH3HUXTSQ==== not decryptable due to an unauthentic ciphertext.
12:09:57.316 [Thread-427] WARN  o.c.cryptofs.CryptoDirectoryStream - G:\######\######\d\EE\G76HJQF2TTXMGHNKROHXC6O2QSQ76R\0QRNMT3MYXDIBHVBHLCTEC7AGE5C24MMZDSV7WXGNWSQSYEIHYFR7X22EBY====== not decryptable due to an unauthentic ciphertext.
12:09:57.317 [Thread-427] WARN  o.c.cryptofs.CryptoDirectoryStream - G:\######\######\d\EE\G76HJQF2TTXMGHNKROHXC6O2QSQ76R\0ET2XVQZNRCAP4UWGIAZB5Y2K25F6IJBWBDCS46QTCVMMN4PYT66Q==== not decryptable due to an unauthentic ciphertext.

You mentioned that a number of computers do not have this issue. Have you checked on such computer if this file exists (or one of the other problematic files)? E.g.,


To give you some context: Encrypted filenames that begin with a 0 (zero) are so-called directory files. Since these filenames can’t be decrypted, it makes sense that you can’t see these subfolders in the virtual drive.

Maybe if you can find a difference in this folder ...\d\EE\G76HJQF2TTXMGHNKROHXC6O2QSQ76R between the working and non-working computer, it could give us a hint what’s going wrong.

We did do a file and folder count comparison between two machines, one with no issue and one with the mission virtual folders, and they were identical.

But are you expecting the files themselves might be different, i.e. a syncing issue?

I was trying to determine if this file


has the identical name on the working machine. You may also check and compare the file content but the error message “not decryptable due to an unauthentic ciphertext” suggests that the filename is somehow “wrong”.

It could be a syncing issue but that’s hard to tell right now. I’d expect that somehow the filename is wrong even though I wouldn’t know how and why.

Maybe wrong number of = padding chars at the end of the name…?

I was thinking the same thing but the number of characters is divisible by eight. :man_shrugging: But yeah, maybe something like that.

Recently I’ve moved all Cryptomator folders from google drive to Onedrive, after importing the vault some folders and files disappeared.
I saw a lot of errors in the log.

22:06:34.514 [Thread-10207] INFO o.c.cryptofs.ConflictResolver - Found valid Base32 string, which is an unauthentic ciphertext: D:\OneDrive\Vault\d\R6\MMLGKWKR4LR6CYGQE4WK5Q6M6JCFFZ\7GODNEW6XBQUF5XE556Y37D76L3YRAD62VPCIMVDH44OZWAKYX
22:06:34.514 [Thread-10207] WARN o.c.cryptofs.CryptoDirectoryStream - D:\OneDrive\Vault\d\R6\MMLGKWKR4LR6CYGQE4WK5Q6M6JCFFZ\7GODNEW6XBQUF5XE556Y37D76L3YRAD62VPCIMVDH44OZWAKYX not decryptable due to an unauthentic ciphertext.

Currently I’m using the last Cryptomator version also tried older versions and from the mobile same problem.

Do you still have the vault files on googledrive and can you validate if there is a difference between the affected file on googledrive and OneDrive?
Seems like something damaged your vault files or Filenames.

No, all google drive content deleted.
But before that, I’ve compared the affected files there is no difference between the files.

Be aware while using this software, I lost important files,I recommended to backup your files before using this buggy software.
BTW moved to other solution