Not able to run pipenv within mounted directory with custom fuse mount flags

Cryptomator version: 1.6.17 (Mac OS)

my mount options: -ovolname="localdrive" -oatomic_o_trunc -oauto_xattr -oauto_cache -onoappledouble -odefault_permissions -ouid=501 -ogid=20 -oallow_other

I was able to reproduce the same error that was seen when running pipenv install within a mounted cryptomator directory using this python test script below

# python

from tempfile import NamedTemporaryFile

# /Users/asdf/abc is the mounted directory
f = NamedTemporaryFile(


Traceback (most recent call last):
  File "/Users/asdf/xyz/./", line 25, in <module>
    f = NamedTemporaryFile(
  File "/Users/asdf/.pyenv/versions/3.10.2/lib/python3.10/", line 553, in NamedTemporaryFile
    (fd, name) = _mkstemp_inner(dir, prefix, suffix, flags, output_type)
  File "/Users/asdf/.pyenv/versions/3.10.2/lib/python3.10/", line 256, in _mkstemp_inner
    fd =, flags, 0o600)
FileNotFoundError: [Errno 2] No such file or directory: '/Users/asdf/localdrive/abc/.__atomic-writeer5aq2w0'

@tobihagemann im not sure who to tag but would you know? I’m trying to do dev work within an mounted directory located within my home directory. if i try running pipenv install outside the mounted directory, it works fine, so it seems that the pipenv process doesn’t have permission to access the mounted directory even with the -oallow_other mount option

pipenv should be impersonating me as a user, so curious to know why it doesn’t have enough permissions to create a file within the mounted cryptomator vault. am i missing some mounted options which will allow the process to access the mounted directory?

omg i figured it out! the -onoappledouble was causing the file .__atomic-writee to not be created