No files visible in vault after upgrade to 1.5.17 - SOLVED!

I upgraded to 1.5.17 on Windows 10 on two laptops (with the encrypted files synced via DropBox). The upgrade worked fine on one laptop, but on the other the Vault opened but I couldn’t see any files.

After various tests, I solved the problem. The difference between the two laptops was caused by one running Cryptomator on start up (the one with the problem), and the other requiring me to start Cryptomator manually (worked fine after the upgrade).

v1.5.17 contains a new version of the Dokan library (v1.5.0.3000 instead of v1.5.0.1000). When trying to upgrade, you get a message telling you to first manually remove the old version of the Dokan Library in the Windows Apps list. This process requires a reboot. I did this, and of course when I rebooted, the old version of Cryptomator ran on start up. Since the Dokan Library had been unistalled, I reckon Cryptomator automatically switched to using WebDAV. I then installed the new Cryptomator version - 1.5.17 - but Cryptomator kept WebDAV as the Virtual Drive setting. I could unlock the drive but couldn’t see any files.

The fix was simple - I just switched the Virtual Drive setting back to Docany in preferences, restarted Cryptomator, and my files returned. Wonderful!

The Virtual Drive setting is evident in Windows Explorer. When using Docany, the Virtual Drive looks like this: Private (X:). When using WebDAV, it looks like this: Private (\cryptomator-vault@42427\CD_z3MGxwHuw) (X:).

Hope that’s helpful.

© 2021 Skymatic GmbH • Privacy PolicyImpressum