No Access rights

Hey guys,

i just bought Cryptomator 2 and set up a cloud directory but i cant get into it, it says „no access rights“.

In the directory settings the „unlock now“ button is greyed out.

I also created a second directory and it had the same issue.

I re-installed the app and nothing changed, same issue…

Quick update: I’m in contact with @ICEMAN_ZIDANE and trying to find the cause of this issue. Currently, we believe that it has nothing to do with iCloud but something else. Unfortunately, the error message from the log file is not very helpful:

Error Domain=NSCocoaErrorDomain Code=257 "Die Datei konnte nicht geöffnet werden, da du nicht die Zugriffsrechte hast, um sie anzuzeigen."

Usually, the error message should contain the file name/path in question but it doesn’t.

1 Like

As we internally use the LocalFileSystemProvider for connecting to iCloud it could be that the saved URLBookmark for the root url of the vault directory somehow does not work properly. As we use the root url to derive all other sub URLs (including the permission given by the user to the root url) this could lead to the error reported by @ICEMAN_ZIDANE and would also explain why we not even have a file path in the error message.

But we should add more fine granular logging to the LocalFileSystemProvider and LocalFileSystemBookmarkManager in order to get a better understand what actually causes the issue.

I agree, I believe that loading from a bookmarked URL is the culprit as well after having a lengthy discussion with @ICEMAN_ZIDANE.

  • The error is caused by LocalFileSystemProvider because the error doesn’t exist with WebDAVProvider.
  • There is no error when creating the vault when no bookmarked URL is involved.
  • Interestingly enough, the issue also happens with “On My iPhone” so it is not specifically iCloud-related.

But I was highly confused since I’ve never heard of such a case before and I’m unable to explain why this functionality seems to be fundamentally broken on their device. Even though I don’t want to jump to conclusions, their device is jailbroken (even though, apparently, it can be turned “off” and it’s then the same). If that’s actually the cause, there is nothing that we can or should do about it. Nevertheless, more fine granular logging is a good idea.


Long time no see.

I think whatever the issue was last time it did have nothing to do with jb cause others tried it and it worked…

After i updated to ios 15 it was working again for me (also with jb).

Today, i had to access my cloud storage cause today is the deadline for my application and while i was under time pressure i was greeted with the „no access rights“ error (see picture below).

Again, iam on ios 15 for many months now (with jb) and Cryptomator was just working fine 2 weeks ago. Now it doesnt, whats going on?

PS: i have sent you the logs via PM


I tried to login with my Laptop which i had not used before so i linked my vault to Cryptomator and tried to login, here is the error:

Error Code 4VHF:Q9JM:I1GP
org.cryptomator.integrations.mount.MountFailedException: org.cryptomator.jfuse.api.FuseMountFailedException: fuse_mount failed
	at org.cryptomator.frontend.fuse@2.0.4/org.cryptomator.frontend.fuse.mount.MacFuseMountProvider$MacFuseMountBuilder.mount(
	at org.cryptomator.desktop@1.7.3/org.cryptomator.common.mount.Mounter.mount(
	at org.cryptomator.desktop@1.7.3/org.cryptomator.common.vaults.Vault.unlock(
	at org.cryptomator.desktop@1.7.3/org.cryptomator.ui.keyloading.KeyLoadingStrategy.use(
	at org.cryptomator.desktop@1.7.3/org.cryptomator.ui.unlock.UnlockWorkflow.attemptUnlock(
	at org.cryptomator.desktop@1.7.3/
	at org.cryptomator.desktop@1.7.3/
	at$ Source)
	at java.base/ Source)
	at java.base/java.util.concurrent.CompletableFuture$ Source)
	at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
	at java.base/java.util.concurrent.ThreadPoolExecutor$ Source)
	at java.base/ Source)
Caused by: org.cryptomator.jfuse.api.FuseMountFailedException: fuse_mount failed
	at org.cryptomator.jfuse.mac@0.4.1/org.cryptomator.jfuse.mac.FuseImpl.mount(
	at org.cryptomator.jfuse.api@0.4.1/org.cryptomator.jfuse.api.Fuse.mount(
	at org.cryptomator.frontend.fuse@2.0.4/org.cryptomator.frontend.fuse.mount.MacFuseMountProvider$MacFuseMountBuilder.mount(
	... 12 more

I still can’t explain the iOS issue as before, it doesn’t make any sense to me. However, we now have more fine granular logging in debug mode.

Can you please enable Debug Mode, trigger the error, and then send me the log files again?

If you want, review the log files yourself first and redact any sensitive information.

Regarding macOS, we still haven’t found out why this could happen with macFUSE:

Did you go through all the required installation steps regarding permissions? Here is a guide: Install MacFuse and sshfs on macOS Monterey | Irregular Motif

But yeah, my suggestion would be to use FUSE-T since it’s way easier to install.

Edit: Works with Fuse-T (for anyone who got the same issue, choose Fuse-T within the Cryptomator settings page (virtual disk), then close the app and restart it…)

Regarding the issue on the phone, I have sent you the log file a few hours ago. Its in our chat which we started when i had the first issue months ago

I’ve seen them but it doesn’t look like they were created with debug mode enabled. That’s what I meant.

It was enabled but i had only send you the 3 files which were created yesterday… anyways, iam going to send you the whole Log file.