no access permissions to my files

Hi Community,

I can not open or copy any files I have stored in the cryptomator.

According to the error message I have no access rights but I can not change any security settings.

How do I get back to my dat?
Although I have a backup but missing some important files that have come in the meantime :frowning:

What Cryptomator version are you using? Do you mount the virtual drive with WebDAV or with Dokany? What are the access rights to the encrypted (i.e. before unlocking) files like?


I use the cryptomator version 1.4.11 meanwhile. My OS is Win10 Pro 1903.
Unfortunately, I can not say with which version I created the files.
I had already tried it with WebDAV and Dokany. Both with debug mode and without.
These were normal Windows file that I had copied into the Cryptomator vault. I never changed anything about permissions.
When I open txt files, the error message “A device connected to the system is not working” is displayed.

Update: With the iOS app I can open the files but how do I get them back to my PC without sending them by mail myself :slight_smile:

I don’t mean the permissions of the file that you work with, but rather the permissions of the files within the storage location of your vault. Files within the C:\path\to\vault\d directory.

This is now a different thing. Before, you said something about access rights errors. So what are we talking about?

Can you please tell us:

  1. What did you do?
  2. What happened? (exact error text, etc)
  3. What should have happened?

My cryptomator vault is in the cloud on OneDrive. For the cloud, I chose a vault as security.
The path in my system is C: \ Users \ … \ OneDrive \ Vault \

Unfortunately, I had to reinstall Windows 10 after it was crashed by a Microsoft update a few weeks ago.

What happened? (exact error text, etc)
The system tries to open or copy the file but then a pop-up error message appears.
Open error message:
Error message PDF: An error occurred while opening this document. An internal error occured.
Error Messages ODS and ODT: Access was denied.
Error message JPG: The file can not be opened.
Error message TXT: A device connected to the system does not work.

The copy error message is the same for all files:
The source file or from the source volume can not be read.

UPDATE: I tried to copy something to the cloud and got the error message 0x8007016A.
So I could then find out what it is and fix it. By restarting and syncronizing OneDrive.

Ok, I see. The error message depends on the application handling the file. But the cause should be the same.
@infeo any chance a debug log might help here?

It might help or might not. But it wouldn’t hurt to have a look at it.

@4Roland Before you send any log file:
Do you use “Files on Demand”?
Does this error also appear if you create a new vault in OneDrive, move some files into it and open/edit/save these? (with Dokany as Volume provider selected)
And there is still the open question: What are the permisssions of the files and directories in C:\Users\…\OneDrive\Vault\d?