Networkdrive - letter changed after OS Update, connection slow

After an OS Update from WIN 8.1 to WIN10 the letter of the network drive changed from V:\ to P:\ and the connection to all the resourses inside the vault became much slower than it was before. It seams as if there is a delay of about 2 to 3 seconds until the connection starts to work.
What could be the cause for that? Solution? Reinstallation?
Thanks for informations R.X.

It is possible that the OS upgrade changed a registry setting in HKLM\SYSTEM\CurrentControlSet\Control\NetworkProvider that might have an effect on the WebDAV configuration of Windows Explorer. In this case re-installation of Cryptomator might help.

Even better: Try using Dokany instead of WebDAV. Just select it from Cryptomator’s settings. If it isn’t available, you need to install Dokany, first.

Or configure in the setting a dedicated volume letter for your vault.

Thanks for your reply Michael.
This is what I originally did, but since I updated to the last version I can’t find an option to configure that and when I restart the computer there is often a change to that letter ???
This looks really a bit strange! Never had this with WIN 8.1

Thanks for your answer overheadhunter.
I use and used Dokany that’s why I am a bit confused about the letter change.
And after the update to the newest version this keeps going on. After a restart of the Computer the letter changed to O:\ and this causes some problems. For example: I have to rewrite the data safing routines.

@loveforlife If you are using Dokany, there should be no Network Drive.

Do you mean just a normal volume or really a network drive? In the latter case you do not use Dokany. And which version of Cryptomator are you using?

Hello ineo
The version is 1.4.13 and I use Dokany; and you are right: it is normal volume not a network drive. Sorry for that.
How can I fix the drive letter?

Something was demaged. Now I can access the additional options again and fix the drive letter.:relieved:
Thanks for all your help here.

So you weren’t able to access the additional options? This is an important piece of information. Can you please describe what happened before, when you tried to access additional options?

There was only the possibility to unlock the vault.
Now I reinstalled the latest version and afterwards the the possibility to open the additional options was there again.
Now I have some other problems:
First thing what I already told here: When I end the installation process and mark the option to launch Cryptomator the programm starts but there is no automatic password fill and when I copy and paste the password from KeePass 2 it doesn’t accept the password (but that was already before the case). I have to close the application and restart it and the automatic password fill is working again.
My real problem now is that when I want to lock the vault again (after opening it) with the first klick on lock vault nothing happens. With the second klick I get an error message:
There is no file open in an application that could cause it!
This whole story started after the last WIN 10 Update! No problems before!

And some further information: After my first klick on lock vault - nothing happens but when I then klick the arrow to the right and klick on “Show drive” Windows Explorer starts with My Documents folder open.

I did a restart of my computer, logged off and on, still the same thing happens.
So it looks like as if the vault locked but normally I should have the possibilty to open the same or another vault after that, but the only tab I can klick is: Lock Vault which triggers the error message. SO I only can close the programm. And sometimes after closing the programm I can still find it in the task manager and the system tray (not always).

Interesting, this might be a bug. Possibly because the installer runs with elevated privileges and thus the per-user saved passwords aren’t available.

This has been discussed here:

Now I found out what causes this above mentioned problem:
Whenever I take the mark away from “Show Drive” in the advanced options and then directly klick on “Unlock Vault” it is not possible to lock the vault again.
When I close the program after taking of the mark, restart the program, unlock a vault and then klick on “Lock Vault” everything works fine. It happens only in the case that I take the mark off “Show Drive” in the Advanced Options and unlock a vault directly after that.
I checked it now for some times, even reinstalled the program, checked again; it is always the same error message and the same behaviour of the program as mentionened above.

Seems like a downward incompability on the Dokany side:

The solution is to upgrade Dokany to version

SO sah die Laufwerksanzeige zuletzt aus!
Ja, nach der Installation von der neuesten Dokany-Version läuft wieder alles bestens. War aber gar nicht so einfach, da ich die frühere Dokany-Version mit einem anderen Admin-Konto installiert hatte und da gab es diverse Schwierigkeiten bei der Installation - Deinstallation - Installation, aber das gehört nicht hierher.
Allerdings erwarte ich, dass ich bei einer Installation einer neuen Version von Cryptomator darauf hingewiesen werde, dass es auch eine neue Dokany-Version benötigt. Würde auch einiges vereinfachen, wenn das alles in einem Gesamtpaket verarbeitet wäre, sodass ich mich bei der Installation nur noch entscheiden muss, ob ich mit WebDav oder Dokany arbeiten will und dann automatisch die richtige Version mitinstalliert wird.
Mit freundlichen Grüssen Xaver Reichart

Leider wussten wir nichts von der Inkompabilität. Dokany wirbt mit der Abwärtskompabilität und deshalb gingen wir davon aus, dass der Übergang ohne Probleme verläuft. Selbst während der Zeit des Release Candidates erhielten wir keine Meldungen und erst nach der Veröffentlichtung der offiziellen Version meldeten sich viele Nutzer.

Der Installationsprozess von Dokany ist definitiv noch verbesserungswürdig. Allerdings ist dass auch eine Sache, die nicht in unseren Hände liegt. Wir haben bereits bei den Entwicklern von Dokany angefragt, aber noch keine Antwort erhalten.

Un zu guter Letzt:Es gibt übrigens keinen “WebDAV”-Version. Falls Dokany Probleme macht kannst du immer zu WebDAV wechseln, weil hierfür die native Implementierung von Windows genutzt wird. (;

Danke für das ehrliche Feedback! Wir haben in der Tat grade erst den Installer in Hinsicht auf Dokany so weit es geht verbessert. Unter anderem muss nun, sofern man Dokany auswählt, keine Visual C++ Runtime Library mehr manuell installiert werden. Diese ist nun Bestandteil des Installers.

Das große Problem ist, weshalb wir auch mit den Dokany-Entwicklern in Kontakt stehen, dass Dokany nicht upgradebar ist, sondern man manuell die alte Version deinstallieren, dann neustarten, dann die neue Version installieren muss. Wir hoffen, dass dies verbessert werden kann.