Moved files cannot be opened

Cannot OPEN moved files.

MacOS 13.2.1
MacBook PRO M1
Craptomator: 1.6.17 (dmg-4104)


  1. Open Cryptomator Vault in Finder
  2. Use Mouse to move one file into another Folder (within Cryptomator)
  3. Open Targetfolder and try opening that file - ERROR: “File.pdf” can’t be found

the same file can be used as attachment in an e-mail. There it can be opened
The same file can be duplicated - and the duplicate can be opened, while the original (moved file) still can’t be opened…

Temporary fix:
Lock Vault and Unlock it again. The file can be opened.

Cryptomator can't open moved files

I just installed Fuse-T (experimental)… and updated to Cryptomator Version 1.7.2 (dmg-4356)

and the problem seems to be reduced.

After moving a file from one folder to another folder (within the same Vault), it sometimes says FILE NOT FOUND, but clicking on it again and again (3 or 4 times), it eventually opens.

It seems to work, but not very stable though…

To be honest, I’m not very confident with Finder on macOS 13.2.1 at the moment. We found a very serious bug that has nothing to do with Cryptomator. This was my bug report to Apple (FB12023719):

After renaming a folder, I’m unable to open the files inside it. Finder fails with an error: “<filename>” can’t be found.

Reproducible steps:

  1. Open Finder in columns view
  2. Locate any folder that contains files
  3. Rename folder
  4. Try to access any file inside that renamed folder

It’s also very important where you “click” since the issue can’t be reproduced if you somehow bring Finder to “refresh” its state (at least that’s what I assume). Just make sure to follow the steps exactly as shown in the attached screen recording.

I’m using the latest stable version of macOS 13.2.1 (22D68) and was able to reproduce this error on at least 3 different Macs.

BUT, now thanks to you, we found a second scenario. I was able to reproduce your steps as well. BUT, your scenario doesn’t seem to work “everywhere” in Finder. I only managed to reproduce it in a network share (again, without Cryptomator being involved).

Something is just broken in Finder right now…

That is a strange behavior you described above. I tried to reproduce the steps you mentioned, but in my case, simply renaming a folder (in column view, with files inside, just as described by you) and not clicking anywhere else, allows me to open the files at once. I never had this error in the FINDER …

Maybe it’s not always reproducible, maybe you have to be fast, I don’t know the factors but I’ve already reproduced it on multiple Macs. That can’t be a coincidence. I’ll try to upload my screen recording somewhere.

Be aware, I’ve reproduced this in my Downloads folder on my main SSD.

Correct - I could reproduce it in the DOWNLOADS FOLDER, and by being fast. The error FILE NOT FOUND also appeared.

But after 5 seconds, the file could be opened normally. STRANGE indeed.

Yes, somehow Finder behaves differently on the local file system, maybe it simply “refreshes” much more or clears some internal cache. On a “non-local drive” (I can’t find a better term), Finder might try to work more from the cache to save “requests”.

Anyway, the cause is in Finder and from our point of view there is really nothing to fix. I ran the same scenario on an old Big Sur Mac and there was no bug yet. Apple has to do something about this.