Modified date changes to current date when copying a file into the vault


The issue I am looking for help with is pretty much the title.

There are a few threads about the topic but none are really the same as my scenario and no suggested solutions helped me.

Cryptomator version: 1.11.1
Volume Type: WinFSP [also tried WinFSP (local drive) with the same result]
Operating System: Win 10 Home 22H2
File manager used: Windows explorer

When I copy a file with a modified date some time in the past into my unlocked vault, the modified date in the vault gets set to the current (today’s) date. The expected behavior would be that the modified date gets copied with the file and stays the same as it is for the original file.

When changing the volume type to WebDAV it works correctly (keeping the modified date of the original file) but this volume type reports errors when the path is longer than about 200 characters so it is not an option for me to use that instead.

When I updated to Cryptomator 1.11.1 it had a message about needing to install a new WinFSP version which I confirmed so I think it is using WinFSP2 but I am not sure where / how to confirm this.

Any help with issue is greatly appreciated.

I’m seeing this problem too as of this 1.7.1 version

I am using cryptomator 1.11.1 and WinFSP .
(on a windows 11 machine).
Unfortunately I cannot reproduce this.
If I copy a file into my vault, the file date stays unchanged.

PS: @Acordov11 you should not use such an outdated version of cryptomator? 1.7.1 was released 8 month ago. And there were some serious issues with version 1.7.x. I highly recommend not using this versions anymore.

Thanks Michael for testing this under Win 11!

I unfortunately don’t have a Win11 machine to test if that is the differentiating factor but it sounds like it.

What is the best way to move this towards a solution? I think it’s clear that this is an issue and should work if Win10 is supported.

Should I create a Github issue for this?

You can open the installed apps and check if Winfsp is installed in version 2.x

Where is your vault stored? PCloud has some issues with Cryptomator.

Thanks Infeo for the instructions with screenshots! I confirmed that I have the same version installed as is shown in your screenshot.

“Where is the vault stored?” Good question and something I had not considered. It is stored on an external SSD harddrive that is connected to a Linux Mint Server and made available in the network as a samba share.

Your question got me curious so I did some more testing and it seems like where the vault is stored is actually making the difference.

Vault on Linux Mint server shared through samba: Issue exists (modified data gets set to current date instead of being copied)

Vault on Win10 Pro PC shared over windows folder sharing: Issue exists (modified data gets set to current date instead of being copied)

Vault connected to same windows PC that is unlocking the vault (local direct USB connection, no network involved): Issue does NOT exist (modified date gets copied correctly)

So It appears to be an issue only when the vault is accessed through the network but not if the vault is accessed locally through USB. When accessing the drive over the network it doesn’t make a difference if it is a shared folder on a Windows PC or if it is a samba share on a Linux PC.

Any idea on how to get it working correctly over the network? Or if it is a legit bug, how to help getting that bug fixed?

Does anyone have any ideas what to try to get this to work over the network? If not, should I file a Github issue so that it can be officially tracked and fixed?