Mnt not available as source in Chromebook Linux

I managed to install Cryptomator 1.7.3 (flatpak-1) onto my Chromebook’s Linux. From the ChromeOS part I shared my crypto folder (living on Google Drive actually) to the Linux partition, and I can see that with a file manager under mnt/chromeos. However, Cryptomator doesn’t show me that mnt folder at all. Any idea, what I’m doing wrong?

Use the appimage version of cryptomator instead of the Flatpak version of cryptomator. Flatpak heavily restricts app permissions, which can cause the problem you describe. There may be ways to get around that using Flatseal to adjust the app permissions, but appimage is easier imo.

by the way, you probably want to type sudeo apt install fuse3 into your terminal in order to get the version 3 of fuse needed to support cryptomator 1.7.3. on the debian 11 container of my chromebook, everything worked fine in cryptomator 1.6.x appimage, but i had to upgrade to fuse3 to get cryptomator 1.7.3 appimage to work.

Cool tip with the appimage. Thx. However, the current 1,7.x didn’t work, as it was unable to mount the vault. Tried the last 1.6 version and that did the trick.

to get cryptomator 1.7.3 working in linux bullseye 11 (which is the default distro for the linux container on chromebook)

  • sudo apt update
  • sudo apt upgrade
  • sudo apt install fuse3

Then restart the linux container and you should be good to go.

1 Like

Splendid. Worked. Thanks a bunch.