Missing file within vault

os:android

#1

I created a vault in Google Drive from a PC with Windows 10 and put one single (gdoc) file in it. This file is missing from the vault when I try to access it from my mobile (Huawei P10 Lite with Android 7).

I have Cryptomator version 1.2.0 on my mobile and 1.3.3 on my PC. Can you help, please?


#2

I tried to reproduce your problem. I created a gdoc file, a vault in Google Drive on Desktop (Windows 10). I unlocked the vault with Cryptomator and copied the gdoc file into the vault. The vault is synchronized by Backup Client from Google Drive, after this I added the vault in Cryptomator for Android and the gdoc file is displayed in the vault.

Have you synchronized your vault to GDrive? If you have you can also turn on Debug Mode in Settings Menu and unlock your vault again. After the file is not shown here return back to Settings Menu and send us the log file.


#3

I have a similar problem.
I had been using a Cryptomator vault for a few months. Within the vault, I had 3 or 4 directories. One particular directory had a few dozen .txt files. None of the files were particularly large.

Everything was going fine until one day all of the text files within that directory were gone. Assuming they were gone forever, and further assuming that I had mistakenly deleted them all, I continued using the vault.

A weird behavior was discovered with that particular folder. It shows no files. But If I copy a file into that folder it disappears. If I try to copy a file into that apparently-empty folder with the same file name as should have been in there, it throws an error (The destination already has a file named xx.txt).

I renamed the directory to (directory_old, or something like that) and that didn’t change the behavior.
I made a small text file… deleteme.txt and copied it in. DIsappeared
I copied that same text file in again and I get the error. (The destination already has a file named “testfile.txt”)

Cryptomator Version 1.3.4
Behavior is identical on two different machines. Windows 7 and Windows 10 Pro
The files are on a local network drive.
The files are not synced to Dropbox or any similar cloud storage service.
Everything in the vault except that directory seems to work as expected.

Anyone have an idea how to I might recover my text files, repair the folder within my vault, and prevent this issue in the future?


#4

I had exactly the same problem and solved it by using Cryptomator Sanitizer https://github.com/cryptomator/sanitizer

After running Sanitizer the output showed (among other info and warnings)
ERROR SizeMismatch d\UR\CYOF2KPR7YJFD4SAQWCJNG53FPON5U\K33H3KIOHJODQPBLLMSRAEEAFV2ILLDWEHQSEF2FQ3MCZ4GSOWBMRXRUKD656D77PKZYZ2OKPDPXHPB53WEVKKDK expected: >= 88 actual: 0

If I remember correctly I just removed the file in the respective folder from my vault, and by miracle all missing files reappeared.

Be sure to make a backup of your vault first before trying this.