macOS Local Sync Files

Softwares used:
macOS 12.1
Delta walker 2.6.2
Cryptomator 1.6.4
Onedrive 21.230 (Mac Store version)

I am trying to sync my files from Cryptomater Vault on OneDrive to a local folder on my MBP.
However it does not work and I get a full bunch of errors from DeltaWalker saying the folders/files cannot be written.

No issue if sync files directly from OneDrive - outside of the Vaults - though.

Thanks for the help.

How do you mount the vault into the system? You can check that under Cryptomator → Settings → Virtual Drive → Volume Type. If you use WebDAV, maybe switching to WinFSP or Dokany could help.

Hum… The volume type cannot be change.

Sorry, I read your post not correctly and assumed you’re using Windows. Usung MacOS you can install macFUSE, after installing you should have an entry FUSE in this setting dialog and the error is hopefully solved :crossed_fingers: .

I am not very keen to use Fuse. I had it when using Boxcryptor in the past and I faced too many concerns…

My aim here is simple. I just want to sync my OneDrive/Cryptomator folders/files on my a disk.
In other words a backup that I will sync every week in case something wrong happens with OneDrive/Cryptomator.

Maybe my way of doing isn’t good. Any recommendation?

PS: In fact the sync works with one folder but not if I sync all OneDrive folders.

If you will stay with WebDAV, you will face limitations.
I really recommend to use FUSE instead.


First of all, I want to mention again that I am running under macOS 12.1.
Also, I never read any where since I use Cryptomator for Apple devices, that there is any limitations of any kind.
The link you are referring to concerns a Windows users, I am not sure it applies to Mac users. Also, regarding the issue mentioned there, I don’t download files larger than 1Gb.
And the info of OneDrive/Cryptomator is also wrong. It shows 5.65Tb while OneDrive is only 1Tb (local HDD is 2Tb). I really don’t understand how it gets 5Tb.

However, I installed FUSE and the results is still the same.

As mentioned before FUSE has never been a very good friend of Mac platform. Even now there are still issues. For instance the access to the module in macOS ystem preferences does not work.

Fuse Error

Regarding the update of the local backup with OneDrive/Cryptomator, the outcome is still bad as the writing of the files does not work. It works only if I sync one folder at a time, which is a nightmare.

Finally, I don’t know if it is because of FUSE, but since its installation I am also facing serious problem to access OneDrive and the Finder is getting unresponsive.

And I can’t even remove anymore the Vaults installed. As you see I have now 2 OneDrive Vaults.