Macos high sierra - cannot write/save files to vault on a webdav server

I’ve been using cryptomator for about a year or so with no issues, however in the last month it seems I can no longer copy files to, or save files to my vault (possibly related to recent os or cryptomator updates?)

I have macos 10.13.6 with with the most recent security updates. I was on Cryptomator 1.4.3 but updated to 1.4.7 yesterday to see if the issues would go away (they did not).

My vault is on a webdav server on my own domain. No problems with normal operations there. I can open the vault and copy files from it onto my computer without issues. But I cannot write to the vault at all. Dragging and dropping with the finder results in ‘some data can’t be read or written error code -36’ error. An empty file does show up, however. From a terminal window, the cp command results in “Input/Output” error. Trying to save from any application into the vault also fails (but empty file is created). From the terminal using the touch command also generates “Input/Output” error - although the file is created.

I can create and copy files to the vault from my ipad as normal - I can then copy them to my computer as noted above. But I can longer go the other way.

I even tried rebooting the computer. Any ideas on what else I can try to troubleshoot this and get cryptomator working again?

jrh

1 Like

Hello,

I have exactly the same error behaviour as described by jrh.
I am using macOS 10.14.6 with FUSE for macOS 3.10.2 and Cryptomator 1.4.16.
The Finder error -36 occurs when using FUSE as well as webDAV when copying files to the unlocked Cryptomator vault.
When I copy files to the same Cloud Storage via webDAV outside of the Cryptomator vault I have no issues (also using Finder).
When I use my iOS device with the Cryptomator app on the same Cryptomator vault I have no issues.

I am experiencing this error for many months now hoping newer versions would fix this. But so far no progress unfortunately.
Any help would be greatly appreciated!

Best regards
Tim

Can you retest this with Cryptomator 1.4.17?

Hello,
Sorry it has taken so long to get to this. I downloaded the version from github and it seems to be working. I successfully copied several different types of files to the vault without the issue appearing, and the files looked fine when opening on an ipad. I had stopped using cryptomater because of the issue, but will resume and try to use it daily this week to see if any problems come back.

Thanks,
jrh