MacOS Catalina Error -43

I have my vault on One drive and using MacBook Pro with Catalina, since last week I keep getting Error -43 when trying to write anything to the Cryptomator folder. I only get this error when accessing the Cryptomator folder no other disk access gives this problem. This is a very generalized error code used by MacOs and can indicate a number of problems.
I have followed all of the Apple suggestions on fixing this problem but nothing has worked.
Is there anything that I can do from the Cryptomator side that may fix the problem

What virtual drive technology are you using? (can be found in the general settings of cryptomator)

I am using WebDAV port 42427

As a workaround you can try to use FUSE.

Regarding the error, i found three other posts mentioning this error:
The first one was solved by updating Cryptomator (i don’t know which version you are using)

The second one was solved, by removing Spaces inbetween the vault name:

The third is still unanswered: Can not delete files inside Vault - error code -43

Thank you all for your assistance.
I installed latest Cryptomator and change from WebDAV to Fuse and the problem is solved.