Mac issues not enough space on device

Hi everybody,

new to Cryptomator running into a bunch of issues…

Mac OS X 11.2.3 (Big Sur),
Cryptomator 1.5.14,
macFuse 4.1.0
Strato hidrive webdav

tried multiple options to place files into Cryptomator vault

  • standard copy from Mac Volume to Cryptomator using Finder - no joy error not enough space on device (while there certainly is more than enough available space in the cloud, creates zero byte files…)
  • tried to use ChronoSync application to sync local folder with folder on Cryptomator vault same situation errors occurring with files not being created …
  • last but not least tried rsync from terminal same thing doesn’t work without errors, here an example:
    ![Bildschirmfoto 2021-04-22 um 09.27.56|690x63]
    (upload://dw1bHqU5Xm6TyhRSGt9ybR0xIfw.png)

would much appreciate any recommendations what the proper way of doing this is :slight_smile:

in the crytomator logs I see a lot of msgs 09:18:18.777 [Thread-28221] WARN o.c.c.attr.CryptoBasicFileAttributes - Unable to calculate cleartext file size for /Volumes/webdav.hidrive.strato.com/<cleaned>/PrivateDocs01/d/6W/YQ24AQ7S25QODQMN53OQQSINW47UZU/RTIAeOI1jbTLyWWlM_Ig_2B63D0CSpfxAaHvlRf9k7DjphM6abWz_8O4UE8=.c9r. Ciphertext size (including header): 0

suspected the issue possibly relates to webdav integration with Strato hidrive, tried setup using Apple iCloud with new vault.
there the copy was no issue could use regular finder to copy picture 9,6 GB folder to CM vault all working with no errors somewhat confirmation that earlier issues might be related to underlying cloud storage.
things went sideways when I did access the vault from windows machine.
-Installed iCloud for windows to access mounted existing vault in CM and instead of the 477 objects that Mac OS reports in the directory windows only shows 4 files…

tad at a loss, spent multiple days now get the concept of secure platform independent storage to work and must say I am stunned about the issues I am having for a very basic setup :frowning:
happy to hear if it is me being stupid or missing something really important in the setting things up, read quite a lot of docs and did my share of goggle and forum searching, nothing really obvious that could be wrong …

please help!

Welcome to the Cryptomator Community :slightly_smiling_face:

do I assume right, that your cloud storage is integrated into the system via WebDAV?

I do not use macOS by myself, but the error message suggests, that a lot of files are created, but have a size of zero. This sounds the like the following ticket on our issue tracker:

The question is, why does Cryptomator think there is no space on the drive. Do you experience this also if you use other third party applications copying files to the drive?

For a workaround you can consider using Cyberduck. It has built in Cryptomator support.

will verify further removing the -noappledouble seems to be suboptimal when the vault is accessed from windows and other OS as there is tons of bogus files there document and ._document

Thanks for the quick response!
T.

© 2021 Skymatic GmbH • Privacy PolicyImpressum