Mac completely crashes when create folders or change filenames (Vers. 1.5.13 dmg-2755.123)

Hi all,

since updating yesterday on new version of Cryptomator when I now (i) create a new folder or (ii) change filename for instance in an existing safe (fTresor) Mac always completely crashed and restarted.

Does anyone have same issues or solutions on this?
Thanks Daniel

no problem here - 1.5.13 running Big Sur on MacBook Pro 2018 - might help to know the macOS version and machine you’re using …

I am using MacBook Air 2020 M1 Big Sur 11.2.2

When I was reading a few other posts, there seems to be a problem using WebDAV with Apple M1. Suggestion is to use FUSE. I guess no fix is available yet to go ahead with M1 & WebDAV, hence I’ll try to use FUSE so long.

This is a known bug, see

The WebDAV Implementation of MacOS on M1 Macs seems to be broken. Like it is already mentioned, the current workaround is to use FUSE.

I am quite helpless around this topic, as I am new to MacOS …

As it seems, WebDAV is still broken on Big Sur 11.2.3

I updated Big Sur, Cryptomator and FUSE on my Mac today.

But I am not sure what to do now.

The currrent workaround seems to be to use FUSE instead of WebDAV.
But my remote sync location is a WebDAV server!
I don’t have some FUSE server and also cannot install it, as this is a virtual Linux machine that does not allow to install any kernel modules like FUSE.

I still tried to just change from WebDAV to FUSE in the Cryptomator App, just to test if this still would be possible.

But trying to do, I got a pop-up that says “System Extension”, … could not be loaded. Please open … and allow … from developer Benjamin Fleischer …

But I did that already and got the answer, that FUSE got updated!

Opening thr System preferences in Security & Privacy, I see the message “System software from developer Benjamin Fleischer has been updated”.

So i am totally confused and unable to continue.

Just to explain, I am fairly capable on Windows and Linux, so not a noob - but I totally don’t get MacOS … I do not even understand the basics or am able to interprete it’s messages and so on …

What did i wrong?

To summarize my questions:

  1. Can i just choose FUSE instead of WebDAV in Cryptomator and use it with my WebDAV sync location? Or do I need to set up some FUSE server for this to work?

  2. Can I somehow check, if I have the FUSE kernel extension installed on my Mac and in wich version?
    The Security & Privacy panel just says that it has been updated … but that does not seem to be true, as Cryptomator cannot mount the volume (if that is possible at all, see question 1)

Many thanks

I managed to create a screenshot of that window:

I tried those:

mini:~ tja$ kextstat | grep -i fuse
Executing: /usr/bin/kmutil showloaded
No variant specified, falling back to release
mini:~ tja$

So, nothing named “fuse” is loaded, but maybe the name differs?

I also searched the directory:

mini:~ tja$ find /System/Library/Extensions/ | grep -i fuse
mini:~ tja$

Again, maybe i search for the wrong name.

I found this:

Here, it is mentioned that is is required to check both boxes?!?

So, allow “remote management”?

I really dont like to enable something that allows remote management.
Also, from other websites, I did not get the impression that it is required to enabled this option.

Could please someone who uses Cryptomator with FUSE / macFUSE on a M1 Mac and Big Sur comment on this?
What is really required?

Frustrating, to be honest …

I ran into the same issue with the M1 processor. Still unsure if it is a Cryptomator specific issue with Webdav or if it is a Webdav issue in general. If it’s the latter and anyone has found a fix, would love to hear about it since I use Webdav for other stuff.

Now regardless if Webdav is fixed for M1 or not, or even if you’re in an Intel machine, I really recommend everyone to use MacFuse instead of Webdav, is so much faster and reliable than Webdav which is why I’m guessing Veracrypt/Truecrypt have been using it for the longest time.