java.nio.file.NoSuchFileException: "Not a vault directory" if I attempt to add a vault with a renamed masterkey file

Current Directory version 1.4.15 is … c:\Cryptomator-Data-Local
I created a backup of this origional data into c:\Cryptomator-Data-Local-v1.5.0
Changed also masterkey.cryptomator into masterkey.v1.4.15.cryptomator
Add Vault, Open Excisting Vault , select masterkey.v1.4.15.cryptomator in C:\Cryptomator-Data-Local-v1.5.0

java.nio.file.NoSuchFileException: C:\Data\NewCryptoVault-v1.15.0: Not a vault directory

Error … Not a vault directory
Created new vault in NewCryptoVault-v1.15.0 -> Working ??

Changed masterkey.v1.4.15.cryptomator into masterkey.cryptomator -> Problem solved !!!

You are NOT allowed to change the name of the cryptomator masterkey :slight_smile: :joy:


Cryptomator considers any directory a probable vault directory, if it contains a masterkey.cryptomator and a d directory. These are just basic tests, of course it is still possible that the masterkey.cryptomator is just a renamed jpeg or the d directory contains word documents or nothing at all.

Thanks mate

issue solved.