IOS 17.4 Cryptomator 2.5.0(1201) - only ONE Tresor / safe can be opened

After an update of onedrive this morning, I couldn’t open any safe anymore in iOS latest build :pleading_face:

So I reconfigured onedrive in cryptomator with 2fa
I reconfigured all safes in cryptomator app and which safe I ever wanted to open ( I have three on one onedrive account / share)
Only the 1st one configured in cryptomator I could open.

All other then start with error in the Dateien App of iOS
Reconfiguring the safes help to open all safes, but only the 1st one added will be accessible


Hi. I tried to reproduce that as I had also updates to iOS 17.4 yesterday.
I have 5 vaults located at:
1x OneDrive (4 Business) with 2fa
1x FTP via WebDAV
2x Google Drive
1x Storj S3 Bucket

I can open all of these vaults with no issues. I checked the app and all vaults where unlocked at the same time.
You can try to recreate the connection. Maybe this helps if you had 2fa enabled just recently.

not my issue I have three safes ALL within ONE onedrive business.
Three vaults on ONE source

So your model does NOT reflect my issue.

Try to mount multiple vaults from ONE source :wink:

Not exactly your Szenario as I do not have multiple vaults on OneDrive. But I have 2 vaults on gdrive.
So I thought it was worth to try if I can reproduce that.

Hallo all,
the issue is solved with version 2.5.1(1212) under iOS 17.4

Hi Michael,

I’m using iOS to 17.4.1 and Cryptomator version 2.5.1(1212) and I’m still having the exact same problem as Carsten (not sure how it’s solved for him).

I have 2 vaults stored in 2 different folders in OneDrive. If I add both of them, only the first one can be opened in Files. When I try to open the second one, it displays: Content Unavailable. The folder contents could not be displayed because of unknown error.
Immediately after removing the first vault from Cryptomator, I am able to open the second one. The order of vaults added does not matter. Whenever I get an error opening 1 vault, the problem gets resolved by removing the other vault that can successfully open.

I have enabled Debug mode and attached 2 log files. I scrubbed off some IDs just in case, but if you need the unscrubbed version, let me know your email.
The log files should record me adding the second Vault from OneDrive succesfully, unlocked with password and encountered the error as I tried to open it in Files.


org.cryptomator.ios 2024-03-26–01-46-49-448 - Scrubbed.log (8.5 KB)
org.cryptomator.ios.fileprovider 2024-03-25–13-05-12-446 -Scrubbed.log (10.5 KB)

I have two vaults on OneDrive. Both work well on my computer of Win 11 and Android phone.

However, when I add the two vaults on my iPhone 15, the first added vault can be opened without any issue. The second one shows Content Unavailable - the folder cannot be displayed because of an unknown error.

If I remove the first vault, the second one will work. When I add the first one back, it will show the same error until I remove the second vault.

How can I make both Vaults work on my iPhone?

Thank you

My version is 2.5.1(1212) under iOS 17.4. The issue is still existing on my end.

Hey everyone, thank you for reporting this issue. We’re working on a fix right now, see: Content Unavailable Error with (single) MS OneDrive Accounts and multiple Vaults · Issue #345 · cryptomator/ios · GitHub

1 Like