IOS 17.4.1 Cryptomator 2.5.1 (1212) Can not open Vault on OneDrive

Hello guys,

I have just installed Cryptomator on IOS after Uploading a Vault to my OneDrive with MacOS.
I have bought the onetime license (if this matters) and tried to add my OneDrive Vault.
It gets downloaded, I have to enter my Password and after that it is stuck in the “Adding Vault …” Dialog.
I waited some time but nothing changes.
When I navigate to the Settings the Cache Size calculation is turning endlessly.
I tried to delete and reinstall the app, nothing different.
Any idea? As of now, I can not use it.

Found the solution. I don’t know why, but file explorer on my iPhone had issues (was stuck too, not operable even after restarting the app).
Cryptomator uses the IOS file explorer and as it was stuck, Cryptomator’s explorer also won’t work.
I rebooted my iPhone and everything works just fine!

I don’t know why I have not done it before, but hey you may also have the same issue and forget about the rule no 1. Reboot the system