IceDrive and Cryptomator Issues

Using latest Cryptomator v1.6.11

I’m running into an issue where Cryptomator does not function with IceDrive.

IceDrive has a Windows application (similar to Dropbox/Google Drive) that installs and mounts cloud storage as a local drive. Once mounted, I attempt to create a Cryptomator vault on the mounted drive but receive an error. The same error occurs when I create a local Cryptomator vault and transfer it to the cloud storage and attempt to unlock it (error information located at end of post).

I think that the crux of the error is that the file is technically stored in the cloud, not locally, but this actually doesn’t appear to be an issue when using the Google Drive or Dropbox applications as I have tested (which are also configured to store files only in the cloud and not locally).

Additionally, I am not able to get WebDAV to function properly. When I attempt to use the WebDAV location from Cryptomator, it says that the location is suitable, but when trying to create or access the vault it says no write access. Interestingly, I am able to write to the WebDAV using all other applications, and even Windows with the WebDAV mounted locally, without an issue. This only exists with Cryptomator. I have tried using WebDAV, FUSE, and Dokany all with no success.

Interestingly, I did find that if I mount the WebDAV in a separate application (like AirLiveDrive), I am able to use Cryptomator with WebDAV through that application but not natively. However, this solution prevents the use of the cloud storage on mobile devices where storage cannot be mounted locally like this.

Don’t know if there will be a solution for this other than to use a 3rd party application as an intermediary, but given its hacky-ness and lack of mobile usability, I cannot find a suitable workaround for this issue.

Any support/improvements are much appreciated as I know this is a free product and volunteer community for the most part.

Error Information:

Error Code NTQS:2SQS:2SQS
java.nio.file.NoSuchFileException: I:\testvault\d
	at java.base/sun.nio.fs.WindowsException.translateToIOException(Unknown Source)
	at java.base/sun.nio.fs.WindowsException.rethrowAsIOException(Unknown Source)
	at java.base/sun.nio.fs.WindowsException.rethrowAsIOException(Unknown Source)
	at java.base/sun.nio.fs.WindowsFileSystemProvider.createDirectory(Unknown Source)
	at java.base/java.nio.file.Files.createDirectory(Unknown Source)
	at java.base/java.nio.file.Files.createAndCheckIsDirectory(Unknown Source)
	at java.base/java.nio.file.Files.createDirectories(Unknown Source)
	at org.cryptomator.cryptofs@2.4.2/org.cryptomator.cryptofs.CryptoFileSystemProvider.initialize(
	at org.cryptomator.desktop@1.6.11/org.cryptomator.ui.addvaultwizard.CreateNewVaultPasswordController.createVault(
	at org.cryptomator.desktop@1.6.11/org.cryptomator.ui.addvaultwizard.CreateNewVaultPasswordController.lambda$showSuccessScene$5(
	at org.cryptomator.desktop@1.6.11/org.cryptomator.ui.common.Tasks.lambda$create$0(
	at org.cryptomator.desktop@1.6.11/org.cryptomator.ui.common.Tasks$
	at java.base/ Source)
	at java.base/java.util.concurrent.Executors$ Source)
	at java.base/ Source)
	at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
	at java.base/java.util.concurrent.ThreadPoolExecutor$ Source)
	at java.base/ Source)