I can't open my valut after reinstalling cryptomator- Android

You may have the same issue like mine (though my problem is on windows).

My fix was to use FUSE install of Dokan Library.

  • click the preference icon on top-right corner
  • click virtual drive
  • change volume type to FUSE

Long stories:
I have upgraded Cryptomator on PC1 (uninstall old version and install new version). It prompted to convert the vault to new format. Everything worked fine here. Dokany worked.

Then when I upgrade Cryptomator on PC2 that shared the same cloud drive. I think I did not closed cryptomator when I uninstall it. And I only noticed when I install the new version. It still worked but Cryptomator gives error messages on mounting.

The fix was to use FUSE(fast and recommended) or webdav(slow). Most likely because I had an outdated dokan library on PC2 which is not fully compatible with the vault. I don’t know what was the exact causes though.

I sent the log to support email as requested

The problem of @Semsem_Semsem is related the Android app and not the Desktop one.

Thanks for the log file. It looks quiet normal. I see that you opened a file and returned to Cryptomator. When exactly does the “An error occurred” message shows up?

It was working fine, but suddenly when I tried to open the vault it started to give me “error occurred” then I updated the cryptomator and re-installed it then the application started not to recognize the vault. Thanks to your help I could link the vault to cryptomator but finally when I enter the password it opens and gives “File is empty”!!!

You mean the vault is empty or a file you open in the vault is empty?

When I open the valut there’s no files and message says “folder is empty”
But if I open the valut by file manager I can see one folder together with the master key cryptomator and valut cryptomator
That folder contains 4 subfolders and one of them contains my files in encrypted format. …

Do you recommend any action I can do??? I don’t have access to all my files!!!

Can you please copy the complete vault into a desktop where you have Cryptomator running. Then add the vault there. Do you see your folders there? If not run a vault health check by selecting the vault in Cryptomator → Vault optionsStart health check. Does it show errors?

I’m using cryptomator on Android not windows when I open the valute by File manager I see the files but in incrypted format

If the Android app only opens the vault and does not show any folders, but also no errors, only the vault health check can provide more information. However, this is only implemented in the desktop app that is why I asked you to follow the steps mentioned in I can't open my valut after reinstalling cryptomator- Android - #20 by SailReal

Ok, but my USB is not identified by the PC after installing the Cryptomator and creating the valut on it, once I connect it to my PC I’m being asked for formatting!. I’m wondering why is this option not available on Android!!!

Ignore the first option but the second should work to copy your vault folder to your PC: Transfer files between your computer & Android device - Android Help

The reason for this is that the Android app normally accesses the cloud on demand and does not have the complete vault content available locally (sure, a vault in local storage is an exception to this). A health check would therefore be highly vulnerable to network problems and would take “infinitely” long for large vaults.

I succeeded to do that now, a file called cryptomator recovery is created on my pc what is the next step??

Do you mean a CRYPTOMATOR_RECOVERY folder?

If yes, then there should be all files and folders in there that are “orphan” thus whose directory chain could not be resolved any more and would mean that you have not seen these folders in the vault any more.

The problem with files in this CRYPTOMATOR_RECOVERY folder, however, is that we can’t recover the filenames and file endings because of the file name encryption. We have a script here that can recover most of the file extensions but the names are unfortunately not recoverable this way: Sanitizer: Restore Missing File Extensions (Please ignore the section about the Sanitizer, it is now integrated into Cryptomator).

Tomorrow we will publish an article here that describes the background of this case better, i.e. what is an orphan directory, why can they occur at all, how do I recognize them (health check), how can I repair them again?

Hi, did you publish the article? Pls send link to it.

I couldn’t follow your instructions. Could you share detailed steps to restore missing file extension??

Hello,… is there anyone to help!!!
I really regret buying this crap application I lost all my files and there’s no support!!!

@Semsem_Semsem Did you read the linked post about restoring missing file extensions?
Start at paragraph

and when executing the script on the terminal, replace /path/to/vault-decrypted with the filesystem path to your CRYPTOMATOR_RECOVERY directory.

After the script execution, your files should have a file extension again, if possible.

The article about recovering lost data can be found here: Restore Missing Directories

Unfortunately, I couldn’t follow these steps and I am still facing the issue that

I don’t have enough IT knowledge but only basic knowledge! I attached here how my files appear in the recovery file

There’s an error in resource type check. I got some media files but others are not extracted such as jpg