I can't install current version (1.6.10) on Windows 10

When I try to install the program, I get the following error message: “This application requires Windows 10 version 1803 (build 17134) or newer”.

What can I do? Install a previous version? Which would be the most suitable and where I can download it from?

Thank you in advance for any help.

Hi. Is there a reason why you do not want to update your system?
Windows 10 1803 was released 5 years ago and is pretty outdated.
Windows does also not maintain that version any more. Means it does not receive any security updates since November 2020 (according to Microsoft documentation)