Help required: Vault completely empty despite sanitizer showing 3,000 files and little warnings, folder structure damaged

Anybodys help would be greatly appreciated. Cryptomator folder shows completely empty despite using about 1.5G space and 3000 files. I have spent much time creating the data collection and it would be a huge pity to lose it. I have accessed it many times in the past, a little less recently.

Using Cryptomator with PCLOUD.on Android and W10 PC Have upgraded both few months back.

Now on my W10 PC I tried to open after some time of not using. It started as 1.4.15 and suggested to upgrade and install 1.5.7, but upgrade process failed (reading now here, that possibly not all files were completely locally synced, sorry misunderstood verification during process). So went again back to old version for now. I understand a failure should not cause any damage though.

In the meantime I have spent 3 days trying everything. Even digged out an old computer and phone where it previously worked. On all devices vault appears empty or when using a restored vault directory from a month ago I find 1 pdf in the root directory. Was also able to detect the encrypted root directory if that helps.

  1. Sanitizer checks shows the following
    Vault password:
    Scanning vault structure may take some time. Be patient…
    Wrote structure to Cryptomator.structure.txt.
    2974 files in vault
    Checking the vault may take some time. Be patient…
    Found 46 problem(s):
  • 0 FATAL
  • 0 ERROR
  • 46 WARN
  • 25 INFO

Just a few orphaned directories and files

  1. **Vault decryption results ** in all the files being restored, but all directories names are reset to rootnn and files to unknownfilenn. Which is practically useless. Except some directories in approx the 3rd depth are suddenly showing correct file and folder structure.

  2. Above procedure was run on locally downloaded files so does not look like PCLOUD issue. Open behaviour is the same. checked your comment Empty Vault, but still allocates Space but was hesitant to take action as I don’t have a working environment as mentioned in the article.

Thanks for your help in advance

You can’t just switch between vault version 6 (Cryptomator 1.4.x) and vault version 7 (Cryptomator 1.5.x). These formats are incompatible. Since you’re likely using vault version 6 right now (because you’re able to use Sanitizer) and already did a partial migration, I’d suggest that you do the migration again on all of your files. Files that have already been migrated won’t be affected.

But you mentioned that the upgrade “failed”. What was the error? You can look it up in %appdata%/Cryptomator/upgrade.log.

Wow, Thanks for the speedy response. I believe the file I know tried to open was a historical backup on which the migration did not run yet, but I will keep your comment in mind

Re migration I found below in one of the logs after about 300 files seemed OK moved.

0:27:40.832 [JavaFX Application Thread] ERROR o.c.u.m.MigrationRunController - Migration failed for technical reasons.
at java.base/sun.nio.fs.WindowsException.translateToIOException(Unknown Source)
at java.base/sun.nio.fs.WindowsException.rethrowAsIOException(Unknown Source)
at java.base/sun.nio.fs.WindowsException.rethrowAsIOException(Unknown Source)
at java.base/sun.nio.fs.WindowsFileCopy.move(Unknown Source)
at java.base/sun.nio.fs.WindowsFileSystemProvider.move(Unknown Source)
at java.base/java.nio.file.Files.move(Unknown Source)
at org.cryptomator.cryptofs.migration.v7.FilePathMigration.migrate(
at org.cryptomator.cryptofs.migration.v7.MigratingVisitor.postVisitDirectory(
at org.cryptomator.cryptofs.migration.v7.MigratingVisitor.postVisitDirectory(
at java.base/java.nio.file.Files.walkFileTree(Unknown Source)
at org.cryptomator.cryptofs.migration.v7.Version7Migrator.migrateFileNames(
at org.cryptomator.cryptofs.migration.v7.Version7Migrator.migrate(
at org.cryptomator.cryptofs.migration.Migrators.migrate(
at org.cryptomator.ui.migration.MigrationRunController.lambda$migrate$2(
at org.cryptomator.ui.common.Tasks$
at javafx.concurrent.Task$
at java.base/ Source)
at java.base/java.util.concurrent.Executors$ Source)
at java.base/ Source)
at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
at java.base/java.util.concurrent.ThreadPoolExecutor$ Source)
at java.base/ Source)

Is it correct assumption that maybe they were not all locally synced / fully downloaded?

In that case should I install 1.5.7 again, point to e.g. fully locally downloaded vault and start and see what it says? Pls advise/confirm / Thanks a lot

I’m not familiar with pCloud but from the error message


it seems like that the file could “not be found”, so maybe locally not available? So your assumption might be correct. Yes, re-installing Cryptomator 1.5.7, pointing to a fully locally downloaded vault, and then starting the migration should be the way to go.

Thanks a lot. I tried as told. Result in short > migration ran without problem, but still only one pdf file visible when opening the vault

I upgraded version to 1.5.7 / downloaded an original vault / opened the vault in which step the migration was triggered / migration ran through without any issues / in the log I can see that all around 2400 files were migrated without error /

for every file entries as below (see your mentioned record)
19:58:11.216 [App Background Thread 003] INFO o.c.c.migration.v7.MigratingVisitor - MOVED C:\DATA\BEI\crypt\Cryptomator\d\VS\GRPAYA47XIGPRDQDIYAXEYSUPNKMWE\I2Q6CJR3BOH7P3ZW63KHVSKCLOTS3C3RVM5WQTEFRWTS6QJM4PYDMSIKCILMMXA= to C:\DATA\BEI\crypt\Cryptomator\d\VS\GRPAYA47XIGPRDQDIYAXEYSUPNKMWE\RqHhJjsLj_fvNvbUeslCW6cti3GrO2hMhY2nL0Es4_A2SQoSFsZc.c9r
19:58:11.219 [App Background Thread 003] INFO o.c.c.migration.v7.MigratingVisitor - MOVED C:\DATA\BEI\crypt\Cryptomator\d\VS\GRPAYA47XIGPRDQDIYAXEYSUPNKMWE\IDAR66FZ6Z35P5TYAFYDVA3KUUMGWNWE26HXPA5GB6WOQPOEG5RACFO4HXMXMVN46Q5BM=== to C:\DATA\BEI\crypt\Cryptomator\d\VS\GRPAYA47XIGPRDQDIYAXEYSUPNKMWE\QMEfeLn2d9f2eAFwOoNqpRhrNsTXj3eDpg-s6D3EN2IBFdw92XZVvPQ6Fg==.c9r

Files must be around, but I do not know how to make the files/directory structure visible
Do you see anything strange in above? Any ideas how to bring it back / could it be related to this issue Empty Vault, but still allocates Space?

Thanks for further hints

2 possibilities on the “could not be found” message

  1. Pcloud client has crashed or lost connection at that point.
  2. some files in the local cache are corrupted - can be cleared in the desktop app (make sure everythings synced first)

Should be no need to download the whole vault to migrate - I upgraded a 1tb cloud-side vault in under 10 mins on a broadband connection.

Thanks Amiga1200Gamer.
re #1 At this stage there is no relation to pcloud anymore, as I did the procedure downloading and accessing all files locally. No prob as my vault is small (but important to me)
Re #2 How would you clear the cache?
Have no big hope on that procedure though, as the result (seeing only one pdf) after migration basically matched the result of previously accessing the files from other devices, so is unlikely a localized one.

  1. Did you have such migrations before? I saw on one PC I used version 1.3. Is it possible I missed a previous migration step to 1.4.?
  2. Is there a way to fix the file/directory structure resp. make it visible?
1 Like

Encrypted folders are tricky because it’s not even that easy to determine the root folder, which apparently holds your “one PDF file”. Here is a “trick”:

  1. Make sure you don’t have sync enabled because we’re making temporary changes (that can be reverted).
  2. Rename the folder d to dd (or anything else, just make sure it’s not d anymore) inside your vault.
  3. Create a new (empty) folder d inside your vault.
  4. Unlock that vault with the latest version of Cryptomator.
  5. Check the (encrypted) vault structure and there should be new folders like d/2O/B55NG2WBCNRQK2QQKSOZRFNZ3K7ROR.

Now we have determined the encrypted root folder. Check inside the “actual” data folder dd/2O/B55NG2WBCNRQK2QQKSOZRFNZ3K7ROR (or whatever the name you’ve determined) and see how many files there are. If it’s only one file, it’s probably correct that you can only see one PDF file. If there are many more files, maybe you can post the directory listing here?

You can now remove the d folder, rename dd to d, and re-enable sync.

Thanks so much Tobias. I was able to fix the issue finally.

How I did it was.

  1. Working on an unmigrated 1mth old backup of my vault I found the root directory by searching for files of similar file size as the single pdf showing up.
  2. To verify I decrypted specific file (possible, as still V6) and found it to be identical when opening after changing extension to pdf
  3. I compared the encrypted directory contents of the old backup showing only one file to the content of the recently attempted upgrade to V7 vault and found that latter directory had more than one file/dir in it
  4. So I attempted to finish the previously unsuccessful upgrade, downloading it locally (just in case). It finished fine this time, finding all 200 directories and 2400 files back. Hallelujah!

In retrospective I agree with Amiga1200Gamer that likely reason for my original upgrade error was my internet having connection issues. Also in the past I did not really sync the files to local HD from PCLOUD when working with Cryptomator. This failed attempt left me with an empty vault.

Then attempting to go back to square one and working on a month old backup, seemed a good idea. I have no idea what created the corruption of exactly that directory as I treated the data carefully. Good news is that recovery worked even without relying on an old backup, speaking for your software.

Thanks again both of you very much for your support. Apart from Android I will be buying the PC license as well very soon. Keep up your very good work!


Glad you have your vault fixed now!

Settings/Disk usage.
This is from linux, but the windows interface is of a similar layout.

Re versions/previous migrations, I keep cryptomator quite up to date - at least updating on main point releases 1.3.x, 1.4.x, 1.5.x etc. I always ensure the version is the same across different machines.

Be sure on future migrations not to have the vault unlocked on mobile at the same time. PClouds webdav is not so good, it can keep lots of files locked, which could affect the migration.

Thanks Amiga1200Gamer for the cache clear info and hint on usage.
Will keep it in mind for the future.