Have fun: How to break a cryptomator partition in less than 2 minutes

os:windows

#1

Hi,
I stopped using cryptomator because of this issue:
OS: Windows 10
cryptomator: 1.4.0
Other sofware needed: git

  1. open “cmd”
  2. in “cmd” clone this deposit: “git clone https://github.com/OpenChemistry/avogenerators.git” (for example)
  3. mount your cryptomator partition
  4. copy the git folder avogenerators/ on the cryptomator partition
  5. have fun: try to remove the avogenerators/ folder on the cryptomator partition
  6. Congratulation your only chance is to delete your cryptomator partition completely and make a new one and never backup a git deposit on a cryptomator partition

#2

Curious what you were attempting to do?


#3

Not sure if this applies here, but I had some un-deletable files in a previous version. The way I managed to delete them was to create another dummy file with the same file name and same extension in windows desktop and then copy (overwrite) the un-deletable file. The dummy file was then deletable.


#4

I have this problem. I used freefilesync to sync my files, and for the most part it worked well. A few files showed errors, so I decided to delete those files and try again. That didn’t work (they’d just reappear after a F5), so I tried deleting the folders those files were in. That didn’t work either, and I got error ‘B:\ is unavailable’.
A fix for this would be greatly appreciated! Can I find the files in the encrypted folder and delete the encrypted files to fix this or would it break my vault?


#5

I wonder if the problem I’m seeing is similar to what you’re seeing. I have had time to report it to the Cryptomator devs yet so I haven’t mentioned it here yet.

In my instance, I have my vault inside Dropbox. Standalone banking software that I use creates a backup of my file when I quit the application. I have it set to only keep two backup copies but due to the age of that software (old) and how it handles file access it doesn’t do that since I moved to Cryptomator.

I’m fine deleting the oldest backup file by hand but I find that I can’t seem to do it from the same system that created the file. If I delete it, I don’t see the Dropbox task icon show it resyncing. If I F5 from my vault location in Explorer, the file reappears. Even if I close out my vault and restart dropbox and cryptomator, the file I try to delete keeps reappearing.

The only way I can delete the file is to do so from another computer that’s been syncing everything all along but didn’t create the file(s) in the first place.


#6

If I remember correctly, the problem with un-deletable files appeared when I stored executable (.exe) files in cryptomator vault. I reported it back then (probably version 1.3.3) and it was a known error (something to do with windows too I think). The executable files were being corrupted and then became un-deletable. Since then I stopped storing plain .exe in the vaults and I always zip executable files before I place them in the vault.

I have no idea if this has been fixed in later versions, I still zip all my executables to be sure.


#7

Cryptomator is a “Russian roulette” in my case
Thank to all, I hope the dev who works on Cryptomator read this… the only way I found is to have has less as possible files and folder in the vault, so only about 10 tar.baz2 files for Unix and zip/7z files for Windows. I have this random problem when I have many subfolders and files with long names


#8

Reported and acknowledged here: https://github.com/cryptomator/cryptomator/issues/776


#9

For anyone having problems with write protected files, i created guide to remove the attribute: Windows: How to remove write protection from a file inside a vault

Nonetheless, this will not help in this case, since git uses under windows the write protection attribute and thus will always fail.


#10

Hello Infeo,
Sorry but it is not the solution, I already tried it with the veru last version of Cryptomator:

attrib.exe -R /S “D:\VERIF…ets_vB.4be5.ffs_tmp”
Accès refusé - D:\VERIF…ets_vB.4be5.ffs_tmp

It is in french but it means “access denied”

I try with admin right (on cpryptomator and the command line), but the problem is exactly the same

Maybe we need an update of your solution, or a much better way: fix this CRITICAL (old) bug (or to build an alternative version of cryptomator…)!

PS: it is not a git folder !


#11

@kboo You have to apply the tool onto your encrypted files. Not onto the ones in your unlocked vault.


#12

@infeoYou are right it does something but doesn’t at all (I did it on the encrypted files with Admin right but… many errors, none corrected :scream:

Fichier caché non réinitialisé - C:\Users\user\Google Drive\cryptomator\m\YM\desktop.ini
Fichier caché non réinitialisé - C:\Users\user\Google Drive\cryptomator\m\YP\7E\desktop.ini
Fichier caché non réinitialisé - C:\Users\user\Google Drive\cryptomator\m\YP\7O\desktop.ini
Fichier caché non réinitialisé - C:\Users\user\Google Drive\cryptomator\m\YP\desktop.ini
Fichier caché non réinitialisé - C:\Users\user\Google Drive\cryptomator\m\YS\IK\desktop.ini
Fichier caché non réinitialisé - C:\Users\user\Google Drive\cryptomator\m\YS\desktop.ini
Fichier caché non réinitialisé - C:\Users\user\Google Drive\cryptomator\m\YT\QU\desktop.ini

This application still have a CRITICAL (old) bug that should be corrected as quick as possible