GUI Not Appearing When Upgrading to version 1.5.5 - Unable to successfully revert to prior version

Because Version 1.5.x introduced the new vault format version 7, which is not compatible with vault format version 6 which was used in Cryptomator versions 1.4.x.
If you are now asking yourself: why a new vault format: here’s the answer: Vault Format 7: Behind the scenes

To check which version your vault has, open the Masterkey file with an editor. There’s a line with the version. I assume that you have started the vault migration after installing Cryptomator 1.5.x.
Correct? If yes, was it performed completely or was it interrupted? Is there anything in the upgrade logfile (if there is any)?
Do you have files on demand functions running or is your vault completely offline available?
Any ERROR or WARN Messages I’m your Cryptomator log when you just start Cryptomator or try to open a vault?

The update to 1.5 appears not to have fully launched, so my Masterkey file info still shows as version 6 and presumably the vault migration has not commenced. When version 1.5 runs, it only shows as a process in Windows task manager and not as an application. The vault was completely available offline. The log files show that the UI is shutting down and not simply invisible:

15:45:45.818 [main] INFO org.cryptomator.launcher.Cryptomator - Starting Cryptomator 1.5.5 on Windows 10 10.0 (amd64)
15:45:46.379 [JavaFX Application Thread] INFO o.c.ui.launcher.FxApplicationStarter - JavaFX Runtime started.
15:45:46.387 [JavaFX Application Thread] INFO org.cryptomator.jni.FunctionsLoader - loaded WinFunctions.dll
15:46:03.188 [main] INFO org.cryptomator.launcher.Cryptomator - UI shut down

Not sure if it’s relevant, but I used to have both the 32 bit and 64 bit versions of Java on my machine but only the 64 bit version successfully re-installed this morning and the 32 bit version is unable to.

Michael, also, there are no Error or Warning messages as I can’t get to any user interface to attempt to open a vault. All I see is the Cryptomator icon in the system tray and when I hover on it, I see a dialogue box with options but am unable to select any of them. Thanks,

1 Like

dmoy, he is referring to the app logfile in AppData. I have exactly the same problem, as you noted, so I’ve been through this. You find the logfile in C:\users\ (yourname) \AppData\Roaming\Cryptomator
When you find cryptomator0.log and open it with a text editor, I bet it will show something like this:

20:24:27.664 [main] INFO org.cryptomator.launcher.Cryptomator - Starting Cryptomator 1.5.3 on Windows 10 10.0 (amd64) (AFTER 1.5.5 DIDN’T WORK, I REINSTALLED ALL VER’S LIKE U)
20:24:33.159 [JavaFX Application Thread] INFO o.c.ui.launcher.FxApplicationStarter - JavaFX Runtime started.
20:24:33.345 [JavaFX Application Thread] INFO org.cryptomator.jni.FunctionsLoader - loaded WinFunctions.dll

We have a problem! Since no error is reported, the helpful people here don’t really know what to say, other than “some problems can’t be fixed”. If you really need access to your data, the Cryptomator Android App should still work. Other than that… Good Luck, and keep me posted.

Although this does not fix your issue, you can access your online vault directly via cyberduck.

Have you checked if this thread (and configuration) also applies to your settings?

All I know about Cyberduck is “Cyberduck is an open-source client for FTP and SFTP, WebDAV, and cloud storage, available for macOS and Windows licensed under the GPL. Cyberduck is written in Java and C# using the Cocoa user interface framework on macOS and Windows Forms on Windows.”

What would we need to do to use Cyberduck to view our encrypted cloud-storage (eg Google Drive) data?

My data files are on my Google Drive. Does the workaround apply to me??

To come back to the OP:
Let’s roll out the case again from the beginning, maybe we’ll find something useful on the way.

Stating the facts

I start with just reiterating what is already found out.

Operating System

You reported that your OS is

I am not aware that such a version of Windows 10 exists.

Problem 1: Main window not opening

Your description of the problem is the following:

This is apparently an error.

Problem 2: Tray menu does not work

Additionally you say that

This also sounds wrong. Apart from the entries of your vaults, the tray menu also offers to “Show” the main window, open the “Preferences” window or “Quit” the application.Do all of them not work?

Problem 3: Old versions fail

And lastly you add, that reinstalling an old version also does not let you access your vaults again:

This is also an error. As found out, you didn’t even had the chance to migrate any vault to a new format, so your vaults should open.


After stating the facts, I’d like ask some questions and give you some possible workarounds. I think the most important one is to access your data, so let’s start with the


With Cryptomator 1.5.5 you also installed Dokany 1.3.0. I can imagine that this might causing trouble accessing the vault content with older versions.

Fortunately, Cryptomator offers an alternative to integrate your vault into the system and browse your data. Install an old version of Cryptomator (i suggest 1.4.15), start it and change in the general settings the volume type from “Dokany” to “WebDAV”. You won’t be able to mount into directories anymore, but it should be sufficient.


Your description gives rise to some questions:

  • What is your Windows 10 version? (as already said i don’t know any version)
  • For the tray menu, can you interact with the standard buttons (Quit, Preferences and Show) ?

Also, just recently i viewed a thread where the settings file of Cryptomator was corrupted. Deleting it solved the gui problem. To try this fix you don’t have to delete anything, just go to the location where the log file is located and rename its containing folder (e.g. from Cryptomator to _Cryptomator).


I like to finish this post with a remark. Even though Cryptomator is a Java application, since 1.4.x it ships its own Java. Therefore chaning/updating/reinstalling your Java version does not change anything.

1 Like

We also have a ticket on our issue tracker for this problem:

Thanks for the suggestion. Fortunately, I have another machine that is able to run version 1.5.5 and am hoping to reformat my vault with that. If I am unable to get 1.5.5 to run on the problem machine, I will probably reinstall Windows and hope for the best.

Infeo, thanks for the detailed analysis.

I’m hesitant to try WebDAV instead of Dokany to access my data with a pre-1.5 version of the program, because there was some issue in the past that led me to use Dokany and I do have another machine that I can use to migrate the vault format to version 7. I will rebuild my current machine if necessary to get version 1.5.5 to work. When I attempted to open the vault with older versions after uninstalling version 1.5.5, the application indicated the vault was being opened, but after one hour it had yet to be opened.

Sorry, had forgotten the build number is in there. I’m currently running Windows 10 Pro, version 10.0.19041 Build 19041 and encountered this issue first in my prior build, 18363.

  • I cannot interact with the Preferences or Show buttons. The Quit button is functional, so there is some level of functionality in the GUI.

Unfortunately, no success with this fix.

Happy at least that more users are not experiencing this problem and very sympathetic about the challenges of dealing with the ever evolving Microsoft universe which can be slow to follow the law of natural selection.

I just had the GUI not working anymore because of the settings file (C:\Users\username\AppData\Roaming\Cryptomator) and it’s not deleted when uninstalling the app nor overwritten when installing the app again. I think the setting causing the issue was a drive missing.

On my machine, immediately following a new install of Cryptomator and a wipe of the prior user file, the folder C:\Users\username\AppData\Roaming\Cryptomator contains numbered log files (e.g. cryptomator0, cryptomator3, cryptomator4) and a file named upgrade. The upgrade file is blank and the log files do not contain a drive designation. Is there a settings file in that folder or elsewhere in which you modified a drive designation to restore the GUI functionality?

I had a settings.json file in that folder from the previous installation/settings. I deleted it (since it wasn’t deleted by uninstalling and reinstalling) and my GUI started working. If you don’t have the file then I think it’s another issue.

A fresh install isn’t a bad idea.^^ And since Windows 10 it can be done quite easy :smiley: But it should always be the last resort. And of course, there is also no guarantee that it works afterwards…

@dmoy in the linked github issue I posted a link to a testapp of our graphical framework. Can you try it to and report back if it works?

Thanks for the continued help and very willing to further troubleshoot before re-installing Windows as it will be a project on this machine. When I run helloJavaFX, enter text in the box, and press the test button nothing happens. So am presuming this is wherein the issue is to be found.

I had the exact same problem. For me, a clean install of Windows 10 pro solved it. I presume something on my Windows install was messed up, after changing my motherboard and CPU from Intel to AMD. Windows seemed to run fine, until I stumbled across the problem with cryptomator 1.5.x. But now, after a clean reinstall (do not use the built in reinstall function of Windows), everything is fine.

Oh, no, the button is just an UI element without any action^^

Before the reinstall, can you try the buildkit of Cryptomator (a pseudo portable release)? Instructions can be found in the thread Failed to load JVM.

Thought I had erred in installing the JDK last week as multiple errors were generated when I tried to launch the buildkit version of Cryptomator. Much to my surprise it ran this morning on the second go without incident - successfully created a new vault, loaded content, closed it, reopened, etc. I then attempted to reinstall version 1.5.5 and re-encountered the prior difficulties.

I may begin to rebuild this machine tomorrow afternoon, so let me know if there are any other diagnostics you’d like to run.