GUI Not Appearing When Upgrading to version 1.5.5 - Unable to successfully revert to prior version

Although this does not fix your issue, you can access your online vault directly via cyberduck.

Have you checked if this thread (and configuration) also applies to your settings?

All I know about Cyberduck is “Cyberduck is an open-source client for FTP and SFTP, WebDAV, and cloud storage, available for macOS and Windows licensed under the GPL. Cyberduck is written in Java and C# using the Cocoa user interface framework on macOS and Windows Forms on Windows.”

What would we need to do to use Cyberduck to view our encrypted cloud-storage (eg Google Drive) data?

My data files are on my Google Drive. Does the workaround apply to me??

To come back to the OP:
Let’s roll out the case again from the beginning, maybe we’ll find something useful on the way.

Stating the facts

I start with just reiterating what is already found out.

Operating System

You reported that your OS is

I am not aware that such a version of Windows 10 exists.

Problem 1: Main window not opening

Your description of the problem is the following:

This is apparently an error.

Problem 2: Tray menu does not work

Additionally you say that

This also sounds wrong. Apart from the entries of your vaults, the tray menu also offers to “Show” the main window, open the “Preferences” window or “Quit” the application.Do all of them not work?

Problem 3: Old versions fail

And lastly you add, that reinstalling an old version also does not let you access your vaults again:

This is also an error. As found out, you didn’t even had the chance to migrate any vault to a new format, so your vaults should open.


After stating the facts, I’d like ask some questions and give you some possible workarounds. I think the most important one is to access your data, so let’s start with the


With Cryptomator 1.5.5 you also installed Dokany 1.3.0. I can imagine that this might causing trouble accessing the vault content with older versions.

Fortunately, Cryptomator offers an alternative to integrate your vault into the system and browse your data. Install an old version of Cryptomator (i suggest 1.4.15), start it and change in the general settings the volume type from “Dokany” to “WebDAV”. You won’t be able to mount into directories anymore, but it should be sufficient.


Your description gives rise to some questions:

  • What is your Windows 10 version? (as already said i don’t know any version)
  • For the tray menu, can you interact with the standard buttons (Quit, Preferences and Show) ?

Also, just recently i viewed a thread where the settings file of Cryptomator was corrupted. Deleting it solved the gui problem. To try this fix you don’t have to delete anything, just go to the location where the log file is located and rename its containing folder (e.g. from Cryptomator to _Cryptomator).


I like to finish this post with a remark. Even though Cryptomator is a Java application, since 1.4.x it ships its own Java. Therefore chaning/updating/reinstalling your Java version does not change anything.

1 Like

We also have a ticket on our issue tracker for this problem:

Thanks for the suggestion. Fortunately, I have another machine that is able to run version 1.5.5 and am hoping to reformat my vault with that. If I am unable to get 1.5.5 to run on the problem machine, I will probably reinstall Windows and hope for the best.

Infeo, thanks for the detailed analysis.

I’m hesitant to try WebDAV instead of Dokany to access my data with a pre-1.5 version of the program, because there was some issue in the past that led me to use Dokany and I do have another machine that I can use to migrate the vault format to version 7. I will rebuild my current machine if necessary to get version 1.5.5 to work. When I attempted to open the vault with older versions after uninstalling version 1.5.5, the application indicated the vault was being opened, but after one hour it had yet to be opened.

Sorry, had forgotten the build number is in there. I’m currently running Windows 10 Pro, version 10.0.19041 Build 19041 and encountered this issue first in my prior build, 18363.

  • I cannot interact with the Preferences or Show buttons. The Quit button is functional, so there is some level of functionality in the GUI.

Unfortunately, no success with this fix.

Happy at least that more users are not experiencing this problem and very sympathetic about the challenges of dealing with the ever evolving Microsoft universe which can be slow to follow the law of natural selection.

I just had the GUI not working anymore because of the settings file (C:\Users\username\AppData\Roaming\Cryptomator) and it’s not deleted when uninstalling the app nor overwritten when installing the app again. I think the setting causing the issue was a drive missing.

On my machine, immediately following a new install of Cryptomator and a wipe of the prior user file, the folder C:\Users\username\AppData\Roaming\Cryptomator contains numbered log files (e.g. cryptomator0, cryptomator3, cryptomator4) and a file named upgrade. The upgrade file is blank and the log files do not contain a drive designation. Is there a settings file in that folder or elsewhere in which you modified a drive designation to restore the GUI functionality?

I had a settings.json file in that folder from the previous installation/settings. I deleted it (since it wasn’t deleted by uninstalling and reinstalling) and my GUI started working. If you don’t have the file then I think it’s another issue.

A fresh install isn’t a bad idea.^^ And since Windows 10 it can be done quite easy :smiley: But it should always be the last resort. And of course, there is also no guarantee that it works afterwards…

@dmoy in the linked github issue I posted a link to a testapp of our graphical framework. Can you try it to and report back if it works?

Thanks for the continued help and very willing to further troubleshoot before re-installing Windows as it will be a project on this machine. When I run helloJavaFX, enter text in the box, and press the test button nothing happens. So am presuming this is wherein the issue is to be found.

I had the exact same problem. For me, a clean install of Windows 10 pro solved it. I presume something on my Windows install was messed up, after changing my motherboard and CPU from Intel to AMD. Windows seemed to run fine, until I stumbled across the problem with cryptomator 1.5.x. But now, after a clean reinstall (do not use the built in reinstall function of Windows), everything is fine.

Oh, no, the button is just an UI element without any action^^

Before the reinstall, can you try the buildkit of Cryptomator (a pseudo portable release)? Instructions can be found in the thread Failed to load JVM.

Thought I had erred in installing the JDK last week as multiple errors were generated when I tried to launch the buildkit version of Cryptomator. Much to my surprise it ran this morning on the second go without incident - successfully created a new vault, loaded content, closed it, reopened, etc. I then attempted to reinstall version 1.5.5 and re-encountered the prior difficulties.

I may begin to rebuild this machine tomorrow afternoon, so let me know if there are any other diagnostics you’d like to run.


Hello. As a courtesy, I thought I’d mention what I did to get my cryptomator working when I had the same “no Gui, tray icon does nothing” error. First, after all the previous roll-back installations all failed (just like they did with you), I re-installed the latest version 1.5.3 (exe-166) to a completely new folder Cryptomator2. (I forgot to uninstall the older version.) It still didn’t work UNTIL i DID THIS: i just went to C:\program files\cryptomator2 and i invoked the cryptomator.exe file directly. THAT’S IT! That was all it took to get a working GUI. I’m not a programmer so I don’t know what was the difference from running it directly and using the Windows 10 Start Menu.

Other Notes:

  • I completely backed-up the database folder before upgrading it.
  • Left clicking on tray icon still does nothing, but right clicking works
  • To get Start Menu working, I deleted the old icon and clicked “add to start menu” for the new EXE file. Simple.

Good luck.

Interesting. There should be no difference as the icon in the start menu is just a link calling the Cryptomator.exe in the installation directory. No variables, no nothing. Just calling the exe. (At leaset it is the case in my windows installation)

Interesting, I’ve rebuilt the machine that was having the problems already with a reinstall of Windows and am back up and running with Cryptomator.

The support of the Cryptomator community was very helpful in dealing with this unusual upgrade glitch, especially with regard to the general frustration of dealing with an improbable occurrence. None of my data was compromised, but this ordeal drove home the value of maintaining an unencrypted or alternatively encrypted backup nonetheless.

It is possible that my problem with the upgrade arose from a virus or a hack. After successfully running the buildkit version of Cryptomator, I did some investigating and found that for the first time ever on this machine, the Windows process cleanmgr.exe had recently accessed the internet. My primary antivirus software, Bitdefender, did not report any problem, but I attempted to run Google Chrome’s Harmful Hardware Scan and was not able to and my Malwarebytes installation appeared to have become inoperable - I was not able to launch it or to run the Malwarebytes Support Tool.

Thanks for the support.

Confirming here, after a long while, that my problem with the Cryptomator GUI not properly functioning or expanding from the system tray was in fact caused by a firewall issue. The same problem has been reported by at least two other users. The issue was solved in my case by deleting an old firewall rule for Cryptomator and creating a new firewall permission.