Google Drive Update Issue

I have a Macbook Pro M1 Pro and downloaded Google Stream App.

I also have a Windows 10 Computer with the downloaded Google Stream App.

I add a file (123.docx) through my Macbook > Google Drive > Cryptomator.

I then see it sync’d up (stream) to my Google Drive encrypted.

I go to my windows computer and decrypt my Cryptomator and I see the 123.docx file.

When I make a change in the 123.docx document on my Mac computer, then wait for it to sync, then I go to my windows computer, the windows computer does not show the change.

So I tried playing around and adding NEW documents/files to both Mac and Windows and noted that adding new files on either system shows up for the other system, but deleting/updating from mac does not show up on windows. But adding/deleting/updating from windows does show the change for my mac.

What is going on here?

Update: I also use MacFuse 4.4.1 if that makes any difference.
Update2: I also tried a docx file unencrypted from mac and windows side and made changes to the content successfully on both places without renaming the document and I can see both changes. So It is something to do with cryptomator

1 Like

I’ve now noticed that when I upload files/folders through my Macbook, it shows (imagine 10 files with 10MB each).

Then when I go to another device (ios or windows), and open my cryptomator file, I see some of these 10 files with 10GB and some with 0KB.

But when I look at my macbook’s cryptomator files, I still see all 10 files having 10GB each.

Any idea what is going on?

This is what I see on my mac

and this is what I see on my windows

It appears that only Copy 18 and the copyzz are the only ones that made the full transfer successfully. All the others are corrupted in the windows explorer (and therefore also from google drive > cryptomator)? But when I open it in mac, it works fine.

This is the same situation for whatever file type, docx, xlsx, zip, pptx. I’m trying to play around recently and nothing seems to be working smoothly.

To me it looks like something is messing up your syncs. Or your sync is incomplete. Do you have any messages in the sync client about sync issues?

Doesn’t look like it at all


I have this feeling it’s related to my macbook end for google drive.

I plan on first backing up everything that has been corrupted (probably only 3-4 folders; shouldn’t be hard for me to find and then:

  1. Signing out of all accounts for Google Drive
  2. Signing out of Cryptomator (or “forgetting” the vaults)
  3. Uninstalling Cryptomator
  4. Uninstalling Google Drive
  5. Restart my Macbook
  6. Fresh install of Google Drive Download - Google Drive
  7. Fresh install of Cryptomator
  8. Upload a bunch of random files and see if there’s any other corruption

I’m hoping this will fix the issue since it isn’t a size issue.

The solution I proposed above worked. But after a while, I noticed that my MacFuse was acting up, so I uninstalled it and did some rounds of testing and it all works now.

Do I NEED MacFuse?

It’s recommended to use it instead of WebDAV.

Hmm, thanks for referencing Cryptomator Filesystems & dot_clean on Mac OSX - #7 by overheadhunter

Now I understand why my files have ._~Book1.xlsx so many times whenever I save the file.

Since it’s recommended to use MacFuse, I installed it and it is giving me the same problems as before; syncing issues with Cryptomator to Google Drive on Mac.

So I tested it again and removed MacFuse and it worked perfectly to sync all documents and contents in the document.

While it looks clean in my macbook with macfuse off

It looks weird in my Windows Explorer, but that’s something I can live with to ensure that the files are sync’d up

ok. but the type of virtual file system used to display your vault content in finder/explorer should not affekt the sync process in any way.

I have to say that it has to be a syncing issue, but I think I’ve troubleshoot it where I know it is something related to Cryptomator, but I do not know how to fix it.

When I use the word “change”, it is meant as changes made within the content of the document. In this case, it is with Microsoft Excel in one of the cells.

Scenario A (Testing Unencrypted Google Drive)

  1. Add Book1.xlsx in Windows through Google Drive for Desktop
  2. See Book1.xlsx in Mac through Google Drive for Desktop
  3. Made change in Book 1.xlsx in Mac through Google Drive for Desktop
  4. See changes in Book 1.xlsx in Windows through Google Drive for Desktop
  5. Made change in Book1.xlsx in Windows through Google Drive for Desktop
  6. See changes in Book1.xlsx in Mac through Google Drive for Desktop

Scenario A shows that any changes made in either Windows or Mac has the changes reflected within a few seconds of each other. I did not interact with This means that the unencrypted (not using Cryptomator) syncing on both Windows and Mac using Google Drive for Desktop is not an issue.

Scenario B (Testing Cryptomator and Google Drive for Desktop)

  1. Add Book1 copy 2.xlsx in Windows through Google Drive for Desktop
  2. See Book1 copy 2.xlsx in Mac through Google Drive for Desktop
  3. Made change in Book 1 copy 2.xlsx in Mac through Google Drive for Desktop
  4. Changes are NOT seen in Book 1 copy 2.xlsx in Windows through Google Drive for Desktop
  5. Made change in Book1 copy 2.xlsx in Windows through Google Drive for Desktop
    5a, Despite the changes already made in Mac, I made a different change through Windows
  6. See changes in Book1 copy 2 (1).xlsx in Mac through Google Drive for Desktop, but only the changes made in the Windows excel version.

The above picture shows the Macbook side of things on Finder

The above shows the many file name changes even with MacFuse on, but I believe we are dealing with two issues here. [EDIT: Nevermind, I just went into the Cryptomator Settings and it was set to WebDAV, I’ve changed it to FUSE now]

Scenario B shows that there is something wrong with syncing while using Cryptomator on Mac side, but not on the Windows side.

Any suggestions on what I should do? Before attempting Scenario B, I uninstalled Google Drive and did a fresh restart, download, and test to see if this fixes things.

1 Like

@Tricycle7754 Is your Google Drive on the Mac already migrated to using the new Apple Fileprovider API (you see “Folder location is controlled by macOS.” in the Drive preferences)?

Since my Google Drive was migrated with the latest OS update, I see similar behaviour (files written through Cryptomator not getting synced).


  • copy file into Cryptomator vault → it’s written locally, but either not synced at all or with 0 size
  • copy file directly to Google Drive → it’s synced without issues
  • locate the encrypted file and “duplicate” it in the Finder → copy is synched without issues

My current working assumption is that there’s some kind of incompatibility between writes via MacFuse and the Apple Fileprovider stuff (everything worked just fine with the “native” Google Drive sync).


Yes, my Mac is migrated to the Apple Fileprovider API (i.e. Folder location is controlled by macOS).

Since a few weeks ago, I decided to just use Cyberduck instead of accessing my files through Cryptomator. Since I jump between my Windows and Mac, ensuring that I have the files sync’d is more important than the UI at this point.

I don’t know if it is the MacFuse and Apple Fileprovider incompatibility, but for stability, I’ve seen no apparent issues using Cyberduck on the Mac side and using regular Cryptomator on the Windows.

Good luck!

Quick update: Same behaviour with Fuse-T…

New observation… When I start copying the file, the encrypted equivalent shows up as “Upload pending” in the Google Drive status applet. Then before the actual copying starts Google Drive / Apple Fileprovider seems to determine that the file is ready for upload and uploads an nearly empty shell. The Google Drive file id get not propagated back into the “xattrs” of the encrypted file.

Working theory:
Cryptomator creates/then updates/recreates file and while doing that somehow overwrites/resets the Apple Fileprovider extended attributes? :thinking:

What made it to Google Drive:

What’s the state locally:

$ ls -lah n3braXSpzkctzAKxTRuehPlCfU40Nui-UM98bAx-1-ssQGk_YYg\=.c9r 
-rw-r--r--@ 1 user  staff    11G Jan 27 15:32 n3braXSpzkctzAKxTRuehPlCfU40Nui-UM98bAx-1-ssQGk_YYg=.c9r

Missing xattrs

# attr "broken" file
$ xattr n3braXSpzkctzAKxTRuehPlCfU40Nui-UM98bAx-1-ssQGk_YYg\=.c9r
# attr "working" file
$ xattr N7-zgkJnWCHvIboy-R6S7q5Q3KapEG45DLNYBsv5-YQmcXby.c9r

Btw. the permissions of that file are also “off”… Working files have -rw-------@, broken ones -rw-r--r--@.


Sorry, I don’t have a clue what might cause this. Maybe someone else here?