Going crazy with crypto

i tried to open my vault from another laptop i had used before… the vault opened without all the files visible…i updated to the latest 1.33 from 1.1 and somehow lost all my files in the vault…i have recovered all my “d” and “m” folders i have my masterkey file but i need help to structure them well so they open again…i tried opening using existing vault method but the vault opens with my “d” and “m” folders listed but not the files…please someone help

So you are telling me that you have all files restored but you do no longer have them in the correct directory structure?

In any case you may try to use the sanitizer to restore your vault. You may loose the names of some of the files unless you restore the correct directory structure.

To restore do the following:

  • Create a directory vault anywhere you like
  • copy the file masterkey.cryptomator into vault
  • Create a directory vault/d/
  • Copy all the encrypted files into this directory. There should be no files with equal names.
  • Use sanitizer to restore your data. Replace vaultPath by the path to the vault directory and replace targetPath by the path to an empty or non existing directory of your choice.
       java -jar sanitizer-0.14.jar decryptVault -vault vaultPath -target targetPath

thank you i wil try that option…i tried VaultRepair had no luck. …yes i seem to have located all my encrypted files. my only other issue i seem to notice when i go into 3rd level on the “d” folders that some of the files do not have the preceeding “0”…is that ok ?

The files starting with 0 are actually “directory files”. Details on the encryption scheme can be found here if you are interested. When restoring your files those files will not be used anyway because to do that the correct directory structure is currently required.

One note: I mentioned you may loose the names of some of the files. Actually you will loose the names of all files. To restore the names as well, we would have to modify how sanitizer restores the filenames (which currently requires the files to be at least in the correct directory to restore the name, which is not true in this case).

1 Like

thank you for the help so far…i have tried running the sanitizer but i keep getting the error message …Invalid or Corrupt jar file.i have even done a fresh download but still getting the same error message. thank you for all the hep

ok i have resolved the issue regarding the file…now my next problem
C:>java -jar “C:\Users\Bond Note\Desktop\sanitizer-0.14.jar” check -vault “C:\Users\Bond Note\Desktop\crypto” -deep
# Cryptomator vault sanitizer v0.14 #

Vault password:
Scanning vault structure may take some time. Be patient…
Exception in thread “main” java.io.UncheckedIOException: java.nio.file.AccessDeniedException: crypto.structure.txt
** at org.cryptomator.sanitizer.commands.CheckRunner.writeStructureToOutput(CheckRunner.java:95)**
** at org.cryptomator.sanitizer.commands.CheckRunner.run(CheckRunner.java:55)**
** at org.cryptomator.sanitizer.commands.CheckCommand.run(CheckCommand.java:123)**
** at org.cryptomator.sanitizer.commands.Commands.run(Commands.java:75)**
** at org.cryptomator.sanitizer.Sanitizer.main(Sanitizer.java:16)**
** at java.util.Optional.ifPresent(Unknown Source)**
** at org.cryptomator.sanitizer.Sanitizer.main(Sanitizer.java:12)**
Caused by: java.nio.file.AccessDeniedException: crypto.structure.txt
** at sun.nio.fs.WindowsException.translateToIOException(Unknown Source)**
** at sun.nio.fs.WindowsException.rethrowAsIOException(Unknown Source)**
** at sun.nio.fs.WindowsException.rethrowAsIOException(Unknown Source)**
** at sun.nio.fs.WindowsFileSystemProvider.newByteChannel(Unknown Source)**
** at java.nio.file.spi.FileSystemProvider.newOutputStream(Unknown Source)**
** at java.nio.file.Files.newOutputStream(Unknown Source)**
** at java.nio.file.Files.newBufferedWriter(Unknown Source)**
** at org.cryptomator.sanitizer.commands.CheckRunner.writeStructureToOutput(CheckRunner.java:90)**
** … 6 more**

C:>java -jar “C:\Users\Bond Note\Desktop\sanitizer-0.14.jar” check -vault “C:\Users\Bond Note\Desktop\crypto” -deep
# Cryptomator vault sanitizer v0.14 #

Try to navigate to a directory first where you’re sure you have write access. It looks like you’re currently in C:. You could e.g. navigate to your desktop first:

cd "C:\Users\Bond Note\Desktop"
1 Like

thank you…that worked…now i have a text file
Found 5442 problems
1819 ERROR
3623 WARN

how do i resolve the errors

can anyone direct me on the next step to take…i would like to email my txt file to support so they help

Due to the high amount of errors and warnings, it’s an indication that the masterkey you’re currently using isn’t the same one as the masterkey you’ve used to encrypt your data. Or something else happened during your transfer from your other laptop. How did you transfer the data? I don’t think the upgrade of Cryptomator from 1.1 to 1.3.3 has anything to do with it, at least I couldn’t reproduce the issue.

1 Like