"Folder name is not valid" when trying to copy a folder to new vault

Hi there,

first post, so please be gentle with me :slight_smile:

I’m using Cryptomator with Dokany (current version 1.5.0.300) for a long time now without any issues.
The vault is located on a QNAP NAS and accessed by SMB2.

But after I upgraded to 1.6.3, I had problems to open some files.
Therefore I decided to create a new vault, which was not a problem. But as soon as I try to copy some data into it, I’m getting the following error in Windows Explorer:

“Folder name is not valid (0x8007010B)”

When I look into the decrypted vault, the folder has been created as zero size file which I can’t delete.

I created several new vaults, used different clients and folders, but the issue is always the same.
When I create a new vault on a local HDD drive, everything works fine. No issues.

I guess it could have something to do with the cleartext filename length, which is limitted to 44. If yes, could you please explain why Cryptomator set this limit.

As I’m not allowed to add attachments you can find the debug log here.

Thank you.
Jas Man

Hi again,

I’m pretty sure now that the cleartext filename length is the culprit.

I’ve captured the network traffic during mounting the vault for the first time, and it seems that Cryptomator tries to determine the max. length by creating files with different lengths. And according to the result, the value in the settings.json will be set.

The value was different for all vaults that I’ve created. It differs between 2 and 44.
I’ve changed some settings on my NAS, but unfortunately without any success.

Jas Man

With very high probability the culprit is not your NAS, but Windows.

Adding a network storage in the Windows explorer restricts the maximum displayable path to 260 characters for this storage. The deeper the vault is nested into mounted networkstorage point, the less characters a filename can have.

To be clear: The explorer allows copying dir strucuters exceeding the above threshold, but as soon as you want to list a directory with an exceeding path, an error is thrown.

The workaround is to place the vault as close as possible to the storage root and to use short names for any parent directory.

@infeo Thank you for your reply.

I did some more tests and it seems that the NAS is the culprit or at least the current SW version QTS5.0.x
A friend of mine is having the same NAS model as me, but with the previous SW version QTS4.8.xxx installed. When I create a vault on his NAS with the same Windows client, the value of “maxCleartextFilenameLength” is always 2147483647. Same behaviour on my TV HDD recorder, which is accessable by SMB. In both cases copying files into the vault works fine.

So I guess my first conclusion, that this happened after I’d installed Cryptomator 1.6.3, is wrong. Looks like this happens since I’ve updated my QNAP NAS to QTS5.0.xxx.

Any idea whats going wrong here, or what I can do to prevent this? Do you agree that the low value of “maxCleartextFilenameLength” is the reason why I can’t copying files to the vault?

Solved.

It seems that Windows Defender was the culprit. I added “Cryptomator.exe” to the process exclusion list of Windows Defender, and now vaults are created with the “maxCleartextFilenameLength” value of 2147483647 again, and I can copy data into it without any error.

Interestingly I can also remove “Cryptomator.exe” from the exlusion list again, and new vaults are still created with the same value. :thinking:
Maybe someone can explain that behaviour.

1 Like
© 2021 Skymatic GmbH • Privacy PolicyImpressum