First install, unable to configure

I have never used Cryptomator. I just installed ver 1.4.6 on Ubuntu 18.04 via PPA, I open the app and see the gui as expected. I left all settings as default. I tried to add a vault and a window opened at “/tmp/.mount_cryptoSCizMq/app/” with a list of jar files. I was expecting a different setup window. Am I missing something. I rebooted and got the same thing.

Update: So I uninstalled 1.4.6 and installed 1.3.2 via deb. Same results. I get the following screen when trying to create a new vault:

Starting with 1.4.x, Cryptomator is distributed as an Appimage, which means the application is not “installed” to normal directories but rather get’s mounted to /tmp when executing. What you’re seeing here is the mounted application directory.

You shouldn’t end up here (thanks for telling us, we need to fix this :wink:), instead you’re supposed to choose a storage location for your vault somewhere more “normal”, e.g. ~/someCloudDir/vaultXYZ.

On the top left of your file picker dialog, you can navigate to your file system root and then you should be able to go to your home directory.

I tried again and successfully created a vault in my home directory on my PC. But I was thinking I could configure my drop box or some other online storage when creating vault. So it appears I would need to install the dropbox desktop app, mount the dropbox drive and create the vault there. Is that correct?

Im not sure, but doesn’t the Dropbox client just sync? I was not aware of that it does also provide a mounted drive.

But in general:
Yes, that is how Cryptomator is designed.
You create the vault local at a place that is synced with eg a Dropbox client or gdrive client to you online storage.
The client then syncs the encrypted files to your online storage.