First Beta of Cryptomator 1.5.0

Oh yes, will do! :+1:


That was fast. Thank you.

I think I spotted a small cosmetic error message “vault cannot be created…” not cleared when error is corrected on 1.5.0 Beta 3.
How to create:
add vault, create a new vault, choose a name for a vault, custom location, choose, now pick an excisting folder with some content (the folder you want to encrypt but should not already exist),
now you receive an (correct) error message “vault cannot be created at this path because some object already exists”, click back, remove the folder, click next,
now you get the same error, but the path at the storage location does not exist anymore, and you cannot select “next”, so it looks like an incorrect message (message not cleared).
If you selcect the “choose” option again and you select the (same) location, then you still get the (incorrect) error message, but you can select the “next” button and continue to create the vault, no harm done.

Windows 10 Defender detects virus during mount of vault (solved I think)

Cryptomator 1.5.0-beta3
Dokan Library (x64)
volume type dokany
mount using custom path
no change to custom mount flags

I don’t have a github account and I am not sure it is a cryptomator issue, looks more like dokan(y), so I decided to post it in this forum, but I am not sure if it still being monitored.

Opening a vault failed with a popup window with text:

Unlock Vault
An unexpected error occurred
This should not have happened. Please report the error and-so-on

Also at the same time a Windows10 message popup, a Windows Defender message (in Dutch):

Bedreiging geblokkeerd
Status: verwijderd
Bedreiging gedetecteerd: Exploit:JS/Pdfupf.D and-so-on

last line reads:

Betrokken items:
boot: \Device\Volume{d6cc17c5–4085-bce7-964f1e9f5}

I checked in powershell all guid’s but this one does not occur.

Stopping Cryptomator and trying to mount again gave the same error.

Rebooting computer (Cryptomator auto started) solved the issue, I can mount the vault again and issue didn’t re-occur (yet).

I do have screenprints of the Cryptomator popup and the defender popup

Complete error message gave me a hint:

org.cryptomator.common.vaults.Volume$VolumeException: Unable to mount Filesystem
	at org.cryptomator.common.vaults.DokanyVolume.mount(
	at org.cryptomator.common.vaults.Vault.unlock(
	at org.cryptomator.ui.common.VaultService$
	at org.cryptomator.ui.common.VaultService$
	at javafx.concurrent.Task$
	at java.base/
	at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(
	at java.base/java.util.concurrent.ThreadPoolExecutor$
	at java.base/
Caused by: org.cryptomator.frontend.dokany.MountFailedException: java.lang.IllegalStateException: Mount failed: Cannot assign a drive letter or mount point. Probably already used by another volume.
	at org.cryptomator.frontend.dokany.MountFactory.mount(
	at org.cryptomator.common.vaults.DokanyVolume.mount(
	... 8 more
Caused by: java.lang.IllegalStateException: Mount failed: Cannot assign a drive letter or mount point. Probably already used by another volume.
	at java.base/java.util.concurrent.Executors$
	... 4 more

The Cryptomator vault is backup-ed to cloud using the jottaclient desktop client. and it looks like that client is holding the mount point, because after terminating the Jottacloud client, Cryptomator (after restarting cryptomator) was able to mount the vault.

So it is reproducable. A pity that both clients can’t work together.