Files Not Visible in iCloud when accessed via iOS App

I’ve been using Cryptomator for 6 months or so, generally saving files to iCloud vault via PC (Windows) and accessing them via either iPhone or PC.

I just noticed that the files that I’ve recently saved to iCloud vault from my PC are not showing up when accessed via iPhone (Cryptomator 2 app), but they can be accessed via PC. This affects files saved only within the past 6 weeks (I can still access those files saved through April).

I’ve uninstalled and reinstalled the phone app; confirmed that Cryptomator, Files, and iCloud Drive all have cellular access turned on in iPhone settings; confirmed that I’m using the latest version of both iOS and Cryptomator on my phone; and I’ve rebooted my phone.

Any ideas why I wouldn’t be able to see files recently added to my iCloud vault via phone but would be able to access them via PC and/or how to fix the problem?

Thanks!

This sounds like a sync issue on one of your devices. You can always check https://www.icloud.com/, which is basically a “source of truth”. Either your PC didn’t sync the vault properly to the cloud or your iOS device didn’t sync the vault properly from the cloud.

Check if the vault has the same structure / number of files / etc. on the web as on your PC. If there is a mismatch, you somehow have to convince iCloud Drive on your PC to sync.

Otherwise, you somehow have to convince your iOS device to sync. Uninstalling/installing Cryptomator on iOS doesn’t help because it accesses the iCloud Drive data on your device directly (as seen in the Files app under “iCloud Drive”). You’ve already mentioned that you’ve checked the cellular access settings but this is indeed a common source of error because iCloud Drive has a “special” option at the very bottom in the iOS Settings under Cellular.

Thank you! You’ve nailed it - it appears that iCloud is not syncing from my PC, which is causing the problem.

Thank you for setting me on the right path on this.

1 Like
© 2022 Skymatic GmbH • Privacy PolicyImpressum