Files disappearing & Integrity Check fails

Hi there!

I recently moved from Boxcryptor to Cryptomator, and copied all my files accordingly.
Initially, the copy was perfect, i.e. all files from the original folder were included in the Cryptomator folder too.

Now, 1 month later, I did another check of the files, and noticed that multiple files disappeared from the Cryptomator folder structure.
When I try to copy the files from my archive back into the Cryptomator folder they are supposed to be in, I receive a Windows “Error 0x8007045D: I/O-Device Error”. (This only happens when trying to copy over files that disappeared. I can still write new files to the Cryptomator folder).

I continued by doing a integrity check in the Cryptomator Windows software.
Here, all 3 checks fail with the error “Check failed: Traversal of data dir failed. See log for details.”.

The underlying OneDrive is completely synced.

Does anybody know what might be the cause of the disappearing files, copying problems, and failed integrity check?

I would really appreciate your help on this! Thank you very much in advance!

The crypotmator integrity check log:

(Sadly this forum will only allow me to upload them as screenshots, due to new-member restrictions on sending links. Sorry for that.)

Hi. It would be much easier to read if you just post the content of the log file as text here.
Do you have your files local available or do you use the file on demand feature from OneDrive?
If its the latter, does having all vault files offline available make any difference?
I am asking because there’s one report with the same error message and it turned out to be a sync issue with OneDrive.

I made the effort and extracted the repeating error message from the picture:
Die im Analysepunktpuffer vorhandenen Daten sind ungültig

According to the Microsoft documentation, this error happen with OneDrive and the Files-on-demand feature. It appears, if OneDrive did not have enough time for clean up and can be solved by running chkdsk on the volume. See also

Thanks @Michael and @infeo,

Indeed it turned out to be a problem with OneDrive and the on-demand feature.
The chkdsk on my main drive worked perfectly, and my files are back safely :grinning:
Thanks to the both of you!!

Obviously I am quite worried about keepiung OneDrive in the on-demand setting now (but I need the on-demand feature as my local storage is quite limited). Are there any precautions or measures I could take to make sure Cryptomator + OneDrive work well together in the future?