Fehlermeldung beim Öffnen des Tresors

Hallo! Ich habe mehrere Tresore in einer Cloud, bei einem davon kommt immer die untenstehende umfangreiche Fehlermeldung wenn ich versuche ihn zu öffnen bzw. ich kann ihn nicht öffnen. Was will mir Cryptomator damit sagen?

org.cryptomator.common.vaults.Volume$VolumeException: org.cryptomator.frontend.webdav.mount.Mounter$CommandFailedException: Command failed with exit code 2. Expected 0. Stderr: Systemfehler 85 aufgetreten.

Der lokale Ger�tename wird bereits verwendet.


	at org.cryptomator.common.vaults.WebDavVolume.mountServlet(WebDavVolume.java:83)
	at org.cryptomator.common.vaults.WebDavVolume.mount(WebDavVolume.java:46)
	at org.cryptomator.common.vaults.Vault.unlock(Vault.java:142)
	at org.cryptomator.ui.unlock.UnlockWorkflow.attemptUnlock(UnlockWorkflow.java:107)
	at org.cryptomator.ui.unlock.UnlockWorkflow.call(UnlockWorkflow.java:90)
	at org.cryptomator.ui.unlock.UnlockWorkflow.call(UnlockWorkflow.java:44)
	at javafx.concurrent.Task$TaskCallable.call(Task.java:1425)
	at java.base/java.util.concurrent.FutureTask.run(Unknown Source)
	at java.base/java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)
	at java.base/java.util.concurrent.FutureTask.run(Unknown Source)
	at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
	at java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
	at java.base/java.lang.Thread.run(Unknown Source)
Caused by: org.cryptomator.frontend.webdav.mount.Mounter$CommandFailedException: Command failed with exit code 2. Expected 0. Stderr: Systemfehler 85 aufgetreten.

Der lokale Ger�tename wird bereits verwendet.


	at org.cryptomator.frontend.webdav.mount.ProcessUtil.assertExitValue(ProcessUtil.java:28)
	at org.cryptomator.frontend.webdav.mount.WindowsMounter.mount(WindowsMounter.java:43)
	at org.cryptomator.frontend.webdav.servlet.WebDavServletController.mount(WebDavServletController.java:102)
	at org.cryptomator.common.vaults.WebDavVolume.mountServlet(WebDavVolume.java:81)
	... 12 more

Wilkommen in der Cryptomator Community :slightly_smiling_face:

Das du einen anderen Laufwerksbuchstaben auswählen musst. Nur seehr technisch formuliert. :sweat_smile:

Hallo Infeo, vielen Dank für den Hinweis. Ich habe mal bei den Tresoroptionen für den betroffenen Tresor geschaut, da war eingestellt “automatisch einen passenden Ort auswählen”. Ich habe mal versuchshalber einen anderen Laufwerksbuchstaben eingegeben, hat aber keinen Unterschied gemacht, ging nicht. Hast Du diese Option gemeint oder was noch was anderes?

Und noch etwas ist mir aufgefallen: wenn ich in den Tresoreinstellungen des betroffenen Tresors voreinstelle, dass der Tresor beim Start von Cryptomator automatisch geöffnet werden soll erscheint die Fehlermeldung und ich kann den Tresor nicht öffnen, auch nicht manuell. Wenn in den Tresoreinstellungen nicht das automatische Öffnen eingestellt ist, kann ich ihn problemlos öffnen. Komisch.

Nein, genau diese Option.

Die Fehlermeldung aus Cryptomator ist eigentlich nur Weiterreichen eines Windows-Fehlers:

Systemfehler 85 aufgetreten.
Der lokale Gerätename wird bereits verwendet.

Das Verwenden eines reservierten/bereits benutzten Laufwerksbuchtaben ist eine nur Ursache (im Kontext von Cryptomator jedoch häufiger). Es kann durch viele Dinge verursacht werden, suche hier im Forum und im Internet nach dieser Fehlermeldung. Eine Ursache ist z. B. die folgende:

Falls du keine Lösung findest, kannst du den Fehler umgehen, indem du eine andere Technologie zur Integration des Tresors in das Betriebsystem nutzt. Dazu musst du entweder Dokany oder WinFSP installieren und in den allgemeinen Einstellungen von Cryptomator im “Virtuellen Laufwerk”-Tab von WebDAV auf Dokany oder FUSE wechseln.

Welche Version von Cryptomator nutzt du? Es gab/gibt Probleme mit einem Timeout während des Systemstarts, eine temporäre Lösung ist in unserem Issuetracker beschrieben:

© 2021 Skymatic GmbH • Privacy PolicyImpressum