Error saving .odt (the xslx of libre 7.0) directly in the vault

Hello,

I have a PC that I have reasons to be using a much older version of cryptomator (v1.4.11). I used to able to open .odt files (like excel) directly from inside the opened vault and to edit and save them directly in the vault.

Since upgrading from libre office 6.4.x. to 7.0.1.2 I get this error when saving edited files directly in the vault:

error

I am using webdav on win 10 pro 64bit and didn’t have any such issue before.
I understand I am using an old version on that PC, so I don’t expect you to spend time on this one. Just wanted to ask if anyone knows what this is and/or if there is any easy fix/workaround.

Thanks!

I cannot say what the difference between the two libre office version is and what is causing this error.
But if you want to stick to cryptomator version 1.4 (for whatever reason), I recommend at least to update to the latest 1.4 version (1.4.17).
Further more you can check if the problem can be solved by using Dokany as virtual file system instead of Windows WebDAV (see cryptomator settings).

I’ve had various similar problems with treepad and calibre on Win 7. It seems to be related to file deletions. For some reason, attempting to delete or rename through certain applications causes problems, but directly deleting through the file explorer doesn’t. I never quite worked out the details.

With libreoffice, there is a locking system involving a lock file that needs to be deleted. Possibly you could turn off the file locking system for your implementation. Here’s one article discussing how to do this:

https://ask.libreoffice.org/en/question/19290/how-to-unlock-file/

No. I don’t even know if we actively enforce it. From my point of view this would require too much effort for the WebDAV virtual volume provider. The workaround I suggest is to use Dokany.

I was talking about the file locking mechanism for LibreOffice, not for the entire CM vault. The link I provided discussed turning off file locking for LibreOffice.

I’m pretty sure Dokany didn’t resolve my file locking/deletion issues, but I haven’t had a chance to try it with 1.5.8 yet.

Oh, sorry, thought you opened the thread and therefore suggested to turn this feature off :sweat_smile: Nevermind!

© 2020 Skymatic GmbH • Privacy PolicyImpressum