Error creating new vault "Could not initialize vault. See log file for details."

MacOS vX.12.6
Mountain Duck v2.1.0(8541)
Cryptomator v1.3.1 (1007)
Google drive and OneDrive

When I try to create a vault on a Google Drive or OneDrive that is mounted with Mountain Duck, after entering my password, I get the error “Could not initialize vault. See log file for details.”

I can write files to Google Drive and OneDrive without issue.

So I tried to make the vault on a local drive. Everything worked fine. I was even able to copy the encrypted files to the server cloud drives. However, “masterkey.cryptomator” will NOT copy. The MacOS error when trying to copy masterkey.cryptomator is “The operation can’t be completed because you don’t have permission to access some of the items.” I changed all permissions on masterkey.cryptomator to be read/write and that did not solve the problem. As I said, I can copy other files, including masterkey.cryptomator.bkup, to the same directory on the cloud servers.

Below is where the error occurs in my log file but there is not enough information there to tell anything.

Anyone else having a problem creating vaults on cloud services?
Any thoughts as to how to solve this issue?


14:24:21.053 [pool-3-thread-1] INFO o.c.common.settings.SettingsProvider - Settings saved to /Users/rdstokes/Library/Application Support/Cryptomator/settings.json
14:24:26.803 [AppKit Thread] INFO o.c.c.common.ReseedingSecureRandom - Seeding CSPRNG with 55 bytes…
14:24:26.804 [AppKit Thread] INFO o.c.c.common.ReseedingSecureRandom - Seeded CSPRNG.
14:24:28.322 [AppKit Thread] ERROR o.c.u.c.InitializeController - I/O Exception Permission denied
at Method)
at java.nio.channels.Channels.writeFullyImpl(

The easy answer is: You don’t have to use the Cryptomator application when you’re using Mountain Duck. Because Mountain Duck already has Cryptomator integrated. You can create/unlock vaults with Mountain Duck.

If you’d like to use the Cryptomator application anyway for some reason, you can totally do so. You just have to make sure that you don’t(!) enter the password when Mountain Duck asks you to do so. Because once you’ve entered the password in Mountain Duck, Cryptomator can’t access the encrypted data anymore because they’re already decrypted by Mountain Duck.