Dropbox: Office Documents replaced by *.tmp Files when saving


I switched from Boxcryptor to Cryptomator two days ago and at first was very happy how smoothly this free alternative works. Now I encountered a problem:

When I want to save an Office Document, I get the error “The file hasn’t been saved”. In the folder of the file, it has been by a *.tmp file. When I rename the *.tmp file to *.xlsx or *.doc, it can be opened in Excel or Word and contains the changes I made before saving.

But of course, efficient working is not possible this way. Closing the vault or restarting the machine does not solve the issue. What can be done about it?


am I really the only one having this problem? I tried a lot of things and did not manage to solve it, but encounter the same issue again and again. Does anyone have an idea? I am using Office 2021 by the way.

I have exactly the same issue. It is related to the mapped drive which seems disconnected for Office… but I don’t know how to solve this yet. Trying to find an answer.

The drives are connected from a Windows Explorer point of view, but when you run the explorer through your Office application (Office 365), you should see that the mapped drives are disconnected.

Same for me Office Pro Plus 2016 / Windows 11 Pro
Sometimes it happens, sometimes not.
Really annoying

I have the same problem using office 365 and windows 10: microsoft excel does not see the cryptomator vault and cannot access anymore sheets stored over there.
I had to move the files outside the vault. Really bad :frowning:
I opened a ticket but receved no help of any kind and this is even worse: means that no support is available.
I am thing to throut away cryptomator and all of its stuff: it’s simply garbage!

I don’t have this problem with .tmp files. All works as expected.

Is anyone of you using Dropbox? The combination Microsoft Office+Cryptomator+Dropbox is causing a bug:

Yes. That may be my problem. I am using Windows 11 22H2, Office 365 (Individual, version 2307), and Dropbox 180.4.4912. The error message in the bug isn’t in English so I can’t read it. But my erorr from Word, etc started off complaining about the network connection, so I suspect this is the same message I had. Also, I downgraded to Cryptomator version 1.6.17. That was the latest version I could find that didn’t have this problem and didn’t have warnings that it wasn’t safe to use.

Update: I decided to see what happens with the latest version of Cryptomator when Dropbox syncing is turned off. (Someone said that worked for them.) This also seemed to work for me.

Hi Tony, could you please explain the steps to turn off syncing?
And what does this mean? Is it not important to have a syncronisation between PC and Dropbox? Is there an impact?

The only way I know to stop Dropbox from syncing is to right click on the Dropbox icon in the Windows toolbar, then select my initials at the top-right and select Quit. Dropbox syncing is indeed important. But the Github issue in this thread had a comment from hassanrazakhalid that Cryptomator started working again if you stopped the syncing. Obviously, this isn’t a good final solution, but for me it is an acceptable workaround until they can fix Cryptomator.

1 Like

With Cryptomator 1.7.0 we changed the default system integration in order to speed up listing huge directories. But this seems incompatible with Dropbox+Office.

You can switch back to the old system integration by selecting “WinFsp (Local Drive)” in dropdown menu of the settings, tab “Virtual Drive”.

1 Like

It seems to work by doing this :

With Admin rights :

net config server /autodisconnect:-1

Context : Using W11 Pro + Dropbox

UPDATE : my bad it has just failed again, so … still don’t know why this issue … really annoying

Yes, indeed. I am using that combination.