DNS Server: cryptomator-vault? Uninstalled Cryptomator and still present!

Why is Cryptomator:

  1. running a DNS server on my device?
  2. install itself as an authoritative name resolution service?
  3. not allowing me to disable this from the options?
  4. not asking the user if this is wanted or not during the installation?


It doesn’t. You can see by the address, that this is just an alias to localhost.

The alias is needed for the WebDAV volume type, see Volume Types — Cryptomator 1.7.0 documentation.

I’m not sure I understand sorry. it says:
Server: cryptomato-vault (located at so this is the what it is meant to resolves (directly or via upstream server I guess) my DNS queries.

So firstly: why doesn’t resolve my domain as per image in the OP? BTW there was a little typo it’s tracker.opentrackr.org, still it doesn’t resolve.

Secondly: I have been investigating an issue I’m experiencing for sometimes now and specifically:
my IP settings via DHCP always have imposed. So, IP, Netmask and Gateway are taked from the DHCP, the DNS always points to and a s a consequence I have no DNS resolution when connecting to a new network (new IP addressing).
To make ti working I need to go and manually change the NS from the NIC settings and impose an IP which is usually the same as the default gateway.

I can’t tell you for certain, but I have the feeling this is a cryptomator issue? How do I find out what upstreams to?

P.S. If security is a risk and you want to be 100% certain a certain domain always resolve as it should, could you not take a different approach and impose on a per domain nameserver resolver? e.g. on Windows:

Add-DnsClientNrptRule -Namespace ".example.local" -NameServers ""

After some more digging I found out Firefox had DoH enabled!
I clearly remember having disable this in the past.
That appeared to be the issue as disabling it allowed me to get the normal DNS IP via DHCP.

On my laptop I solved switching from WebDAV to WinSFP, however on my Windows 11 VM doing so keeps cryptomator-vault as the default DNS server for an nslookup regardless.

Both Cryptomator and WinSFP are updated.

How can I fully remove the dependency top DNS in this second case?

Even worst, I have completely removed Cryptomator form the second device.

nslookup still defaults to cryptomator-vault

Can anyone please shed some light on how to remove this manually?


This is not related to Cryptomator, but to your system configuration. You only see a symptom, which unfortunately relates to Cryptomator because it adds an alias to the localhost ip address.

If you don’t know what localhost or the ip address means, please familiarize yourself with this concept first.

In the end, you have to change your DNS lookup server, as asked in this SO post:

Ok thanks this reference was found in the host file of my WIndows 11: cryptomator-vault

Might I suggest this is removed as part of the Cryptomator uninstall if ever found?

P.S. I did not add this manually what so ever. I can only assume this is part of the standard Cryptomator installation.