Disconnected Network Drive + Document not Saved

Windows 10 22H2 19045.4046
Cryptomator 1.12.0 WinFsp
Sync and cloud storage with Dropbox
Office 365 Apps for enterprise
Excel Version 2401

Disconnected Network Drive - File Explorer
Very often I see the virtual drive in File Explorer as disconnected with a red X as in the picture below. Sometimes it appears normally, sometimes with a red X - no detectable pattern.


However, even when it reads “Disconnected”, the drive is “live” and I can perform all activities with the drive: expand folders; see all the files; copy; paste; delete.

Disconnected Network Drive - Seen from Excel
Sometimes I see the disconnected drive from Excel, when attempting to do File>Open or File>Save as. This red X from Excel may happen when File Explorer shows either red X or normal drive.

Document not Saved
So far it was just ugly, but now we get into the bad, really bad territory. When I click save from Excel, I get a message “Document not Saved”. My original file name is now preceded with “~” (normally denotes an open file) with a size of 1kb and I can no longer open it. A new .tmp file is created with the size of the original file. File name is like this: “64C66E3D.tmp”. Each attempt to save would create another .tmp file.
Fearing that I have lost my data and just minutes from a heart attack, I tried to rename one of the .tmp file as .xlsx, and it worked! So no loss of data so far, but I cannot save my files to the virtual drive. Interestingly, “Save As” does work sometimes, but not all the times.

I understand that this is a very tough issue to troubleshoot - with so many moving parts and variables. I hope that one of the experts would be able to figure it out.

Is it Excel? Is it Office
I tried to open, make changes, save with Notepad - no problems.
I tried the same with Word and I had mixed results. On one machine I was able to save even when the drive as seen from Word showed a red X (while in File Explorer it appeared normal).
But on another machine, I was able to open the same Word file but I encountered an error when trying to save, as in the picture below.


Thanks a Million

Regarding “Document not saved”:

Cryptomator has a known issue with Dropbox, see Dropbox + Word: Failing to save document · Issue #2880 · cryptomator/cryptomator · GitHub.

The workaround is to change the volume type to “WinFsp (Local Drive)” for this vault (you can change it in the vault specific options, or, if you only use Dropbox, in the general preferences of Cryptomator).